Inventables Community Forum

Z axis limit switch

Then when it ask to probe hit manual and you will need to set the zyx manually.

I guess I can try that next At this point I’ll try anything

Thanks for your input and I hope that I can figure this out awful big paper weight if not!

Sounds like you need to start reading. There is plenty of information on here to help you thru.

Are you familiar with these settings:

This is the universal g code sender which can be used instead of easel to move your x carve.

https://winder.github.io/ugs_website/#downloads

1 Like

Perhaps posting a copy of your machine settings here may help. Those familiar with what the setting should be can kinda have a look and see if something in the settings is incorrect.

Open Easel > Machine> Advanced
In the command bar enter $$ and hit the enter key.
a long list of settings will show up. Copy all lines and post it in this conversation.
It could be that something is off and needs a simple value change.

I will do that tomorrow and see if that may be the problem. good news is that the probe test finally worked

1 Like

This may be too late to help you but here is a video I did last year on installing Homing switches in case others have similar problems.

Hi Robert. I just finished assembling my X-Carve and had the same issue as you. The Z-Axis homing switch was working in the machine test but not in the homing sequence test. I looked at the switch as it was going through the Z-Axis homing sequence and it looked like the microswitch arm wasn’t making contact with the little button on the switch. I just took a pair of needle nose pliers and gently bent the arm. Worked perfectly after that.
I hope this helps.

I figured out my problem when I went to put a new power light and the wires were in the wrong ports everything is working fine still trying to figure out easel but good just the same thanks for reaching out to help

2 Likes