Z axis makes grinding noise when testing?

when testing the z axis during machine set up. Its not moving, but when i click the up arrow it makes a grinding noise. is this normal or what should it do?

That is not normal at all. Turn off the power and see if you can turn the Z axis by hand. You should be able to easily turn the Acme rod to move the z axis through its full range of motion.

If it binds or sticks anywhere along the rod you will need to figure out why and fix it. You may have the rod misaligned or the delrin nut may need to be run up and down the threads 10 or 20 times to loosen it up. Use can also spay some PFTE on the rod

thank you. I can move the z axis manually when I move the belt and motor, but seems tight. I will try moving it a lot more to loosen it up. I’m on vacation til Tuesday, but will try it when I get back. Thanks again!!

The Inventables instructions for the ACME rod don’t mention the hand drill delrin nut loosening. It’s listed under the M8 section. I noticed forum posts mentioning this so I did it and it definitely made it quite a bit smoother and looser.

1 Like

Do u have your potentiometers set on your arduino?
I had to set mine higher before my motor ran proper. Especially when I had my v wheels too tight.
Before I set that and I moved my z axis it made a grinding like noise, but it was the motor not getting enough current and missing steps… I thought it was grinding at first, but was just an unfamiliar noise.
I dunno if that’s worth a look or not.

so I tried doing this, When I turn it counterclockwise it gets louder but still doesn’t move by testing the axis. I’ve also loosened the z axis. When I used my hands to move the belt and motor on top, the light comes on.

If you are turning your potentiometer counterclockwise, you are reducing the current which would make it stuggle even more to move. There is a good write up by Manhattan wood projects I think he is called. Try following that for setting your current. Sounds like you will for sure need to set that proper even if this is not the whole problem.

I’d suggest the following:

  • Take the ACME rod off and use a hand drill to run it up and down a dozen times or so. (Breaks in the delrin nut)
  • Reassemble the Z axis, making sure everything is flat and square. Leave the screws holding the delrin nut a little loose. (Helps diagnose if an offset due to the nut is the problem)
  • Leave the V-wheels loose.
  • With the power supply off, find the high and low stops for your Z axis potentiometer and set in the middle of the band. Be gentle when using the pot.
  • Power it up and use the computer to raise and lower the Z axis a few times.
  • Assuming it worked, tighten up the delrin nut and try to raise and lower it a couple times.
  • Assuming it worked, tighten up the V-wheels to where you can’t spin them with one finger, but you can with two.
  • Assuming it worked, carry on to calibration and setting your pots (I made a few videos on them (thanks @CaseyKookla!), you can find them in this thread: X-Carve Maintenance/Troubleshooting Videos - Add Your Own!)

If that doesn’t work, try swapping the motor out with one of the other motors and try again. That will help you diagnose whether the problem is the motor or the power going to it.

Good luck, and let us know what your results are!

1 Like

Did you make out ok getting your machine up and running??

Sorry I went on vacation and won’t be able to get back to it until Wednesday, but don’t worry I will check in and let you guys know about the project. I wanna get to using this really bad.

Thanks again everyone for helping!! I will keep you updated next week

1 Like

Well I loosened up everything delrin bolts on the plate, v wheels. I did run the rod up and down. Feels like it’s getting looser.

  1. this weekend I will use a hand drill to run it up and down, because when everything loosened up. I hear the current, and move s couple millimeters, but when I jog it again it doesn’t move, so I’m thinking the delrin just needs run a lot.
    I do still hear the current like it’s not getting a lot. When I do move the belt with my hand around the z motor to move it up and down, the green light does kick on

Uploading… When I try it now I’m able to jog the z axis now but only one command in each direction and then that’s it. Here’s an example

You have three elements, stepper, wiring and motor and need to figure out which one is wrong.
Install UGS 1.0.9. so you can jog each axis individually.
Swap the motor with one of the motor which is running fine, this will tell you if you motor is ok
Attach a good running motor to your Z axis leads, if it does not run maybe a faulty connection
Attach a good runnin motor directly to the stepper driver without the leads, if it runs there is a problem with the leads.
Verify the amps of the stepper driver, if it is ok but still not running the chance is big it is defective, call inventables and explain your situation