Z-Axis moving up when carving PCB

Hello

My setup:
X-Carve 500mm rail
Nema 23
ACME lead screw

I have started to mill PCB on my X-Carve, but have some problems with the Z-axis.
I followed this tutorial but used Easel instead of Chilipeppr: https://www.inventables.com/projects/how-to-mill-a-through-hole-pcb

I made my own PCB in Designspark, exported the Gerber file and converted it to G-code with FlatCAM.
I found out that Easel doesn’t understand commands like “G00 or G01” but only commands without the “0”. I opened the G-code in notepad and replace “G00 with G0” then “G01 with G1” and so on.

I could then open the G-code in Easel, and the preview was looking fine so i started to carve.
I had set my CUT-Z to be 0,065mm.
I set the Z-zero with the spindle turned on, moving the Z-axis down to the point where the V-bit could scratch the surface of the PCB.
The first few seconds of the carving went smooth, but then it started to not cut all the way through the cobber on the PCB, after about 30 seconds it stopped touching the PCB.

I tried to just mill a square in Easel to test if the error was in my G-code.
The square was 10mm x 20mm and 0.1mm in Z-cut, I zeroed like before, and started the carve it had the exactly same outcome.
I put my finger on top of the Z-axis ACME screw, and when it was milling the square in the PCB, and I could feel the stepper motor moving, it isn’t much but it shouldn’t move at all.

I tried to use chilipeppr to mill the PCB where I used the Auto level function, but it had the same outcome.

All help is appreciated!
Thanks in advance

Have you calibrated your machines (Adjusted GRBL parameters)?
Have you adjusted your power settings (The potentiometers on the GRBL board)?
Have you leveled your wasteboard?
What is most likely is happening is two things:
Your Z axis is loosing steps (increase your Z power)
or your PCB is not parallel to your gantry (level your wasteboard).
If you don’t want to level your entire wasteboard, level a scrap of MDF and place your PCB onto that.

Since your tried ChiliPeppr’s autolevel, its probably mechanical; your Z is losing steps.

I have calibrated the current potentiometers on the GRBL shield, but I could try to crank the potentiometer all the way to the max and try to see if it helps.

I’m using a leveled piece of ABS so it shouldn’t be because of that.

I haven’t changed anything in the GRBL parameters:
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Please describe how you adjusted your potentiometers.
Cranking them to the MAX will not work; so therefore your method to adjust them in the first place makes me think your initial method is suspect.

A definition of terms while troubleshooting: You calibrate your steps per mm, you adjust your stepper motor current.
Please describe how you calibrated your machine.
I doubt you have calibrated because your GRBL settings are still using the default settings.

I haven’t changed anything in the GRBL parameters, because I thought it was good to go when you got it.

I have calibrated the current potentiometers following this: https://github.com/synthetos/grblShield/wiki/Using-grblShield
None of the Nema 23 steppers have indicated thermal shutdown when carving.

I don’t get why it could be the stepper losing steps, when I make it carve a square with one depth of 0.1 mm. The Z-axis shouldn’t move at all when it has begun carving the square.