Z axis not moving enough

I tried carving a sign today and the z axis does not plunge deep enough and is carving air.I have set the machine up before, and it was working fine, but now it only plunges half of what it should, I tried jogging it 2 inches but it only moved 1 inch, x and y are still working fine and moving the proper amount, it is a new linear upgrade, but was working fine

You can either change your micro step setting or steps per millimeter value in GRBL to correct this.

New linear Z axis means you need to adjust your steps/mm. Your linear Z vendor should give you the ballpark number (usually in turns per in) and you can do math to turn it into steps/mm.

I can help with the math if you need it, you just need your vendors ballpark value.

Thank’s Haldor, and Justin. I have changed the $ settings in machine inspector from $102=188.976 to $102= 95.500, this is the setting I had when it was working okay, but somehow it reverted back again, I have reset it again to$102=95.500 but it has made no difference, it is only moving about half what it should

You said new linear Z, meaning it’s diferent than the one you had previously?

It sounds like you just need to do a Z axis calibration.

Yes Justin, it is a new linear , well 5-6 months old but it was working at $102=95.500, but I have not used it for a couple of months

Ok so your $102 is set to 95.5.

Have you adjusted your microstepping settings at all?
If you command a 100 mm jog, how far does it travel?

I am not sure how to adjust the microstepping settings, I have tried to jog it up 100mm from zero and it moved up 25mm

If it moves 1/4 of told distance something changed your micro step setting. Do you have X-controller or G-shield?

What about connection between the motor and the acme screw?
I assume there are set screws that could have loosened?

You in put 100mm and it moves 25mm every time, in both the positive and negative directions?

Are you calling the bottom zero? Because zero is technically the top so is it a physical limit?

I have checked all grub screws and all are tight, the new z carriage is Mirocarve, I have been looking through the forum and found that it has known faults, but it has been used very little up to now and all seems to be working well, I also have the x controller, I have tried jogging in both directions and it is the same, 1/4 of what I input, everything was working fine and I did not make any changes to anything, except an update from Easel, and the $102 changed from 95.5 to 188.976

Ok, travel is 1/4 of input and step/mm value is ~2x.

What happens if you change $102=47,24?

Also, could you post a picture of your xcontroller dip switches?

Thanks Haldor, I have just tried $102=47.24 and it’s still moving at 1/4 the input, how do I know if the step/mm value is 2x, I am new to this and not sure where the dip switches are or what they look like, do I have to open the x controller

In case you didnt you might need to reset the controller for any changes to take effect.

Check this link for a little info:
http://x-carve-instructions.inventables.com/750mm/step8/

Thank’s for the link, I have been reading through it, I did reset the x controller, I just looked at machine inspector again and $102=95.5 has gone back to $102 =188.976, I tried jogging at that setting and it now moves 1/2 the input instead of 1/4

Then $102 should be double the current value.

So change it to be 376.

Sounds like your microstepping is not 2X anymore but maybe 8X

Thank’s Justin, before I got you message I tried doubling the 188.976 to 377.952 and that got pretty close, I did not check it with a calliper but that seems to be the problem, should I fine tune as it is, or alter the microstepping, I don’t know how to alter the microstepping

I’d just adjust steps/mm to get it fine tuned.

The formula for adjustment:

Current steps/mm * (commanded distance / actual distance) = new steps/mm

So, as an example, if you do a 200 mm jog and it goes 195 mm:

377.592 * (200 / 195) = 387.274

Theoretically this can be an iterative process but at the very least, once you get the new value, you should make sure the motion adjusts properly (i.e. move it 200 mm, adjust steps/mm, move it 200 mm to confirm the change worked)