Z-axis not moving right

I jumped onto the xcarve about 3 weeks ago and my z-axis wouldn’t move up and down correctly. The distance was shorter and moved slowly. I switched the z and y to see if it still would do it and it did. I contacted Inventables and they sent me a new board. I hooked it up and tried it out. It worked perfectly fine. I setup my machine and then started moving incorrectly again. Can anyone help me out?

1 Like

Your Grbl settings are probably set wrong because you selected the “post nov 2021” option when you did the easel setup

the easiest fix is to actually re-do the machine setup and make the correct Selections

I would bet that Inventables sent you a board setup for the older machine, because this is what you have, BUT you selected the NEW machine during setup and not all of your calibrations are set LOWER than they should be… Just Re-Do the setup and select the “Pre Nov 2021” option and select any applicable upgrades on the next screen…


That was it! Working perfect. Thank you.

Crazy thing that it was moving fine. I went to start a carve and now its going too deep. Any suggestions?

Unless your redoing the machine setup, then the grbl settings wouldn’t be changing on their own. But you can verify that they are set right…

Here are the defaults, its the $102 for the z movement calibration

Another possibility for excessive z plunging on the older model is loose z belt or the pulleys for the belt, then gravity starts taking over and it’ll lower more than intended…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.