Z axis not retracting sometimes

I have been carving the entire holiday weekend and for the most part everything has gone surprisingly well (except for some v-wheels falling off). They yesterday I started a long (about an hour) cut and when it was about 95 percent done (the outside profile was almost complete) the Z-axis did not pull up before the x and y axis begin to do a fast traverse to the opposite corner. This resulted in a major cut right through the middle of the nearly finished work.

Although I must say I was very impressed with the power of the machine, I had been dropping down .06 inches each pass with a .125 end mill, but the machine was able to cut a .5 inch deep grove at what must have been at least 60 in/min.

I wrote this off to being a fluke and figured it must have just lost a command somewhere. Then I was cutting the same project again (this time without the outside profile cut) and it did the same thing when it was almost done and finishing a pocket cut.

So now I am worried it will ruin every long running project I try.

I am running Easel on a Windows 8.1 i5 laptop that is plugged into power and it set not to sleep or hibernate while plugged in.

Any ideas what may be happening?

I had a similar problem that was due to the acme rod getting full of MDF dust. I recognized it when
I heard the motor stall out but no movement on the Z axis. I blew it off with air, gave it a tiny bit of wd 40, and cycled through the length of the z axis a bunch of times. It seems better now.

Is WD40 compatible with the delrin nut?

The best lub for delrin is air tool oil. We use have used Husky and Porter Cable with great success. Don’t use too much or you could cause dust build up by sticking to the oil.

We always oil the threaded rods, but rarely need to oil the ACME rods.

Thanks for the tip about the oil. I am not really sure that binding caused the problem, the Z seems to move freely on the ACME rod (way better than the threaded rod before the upgrade).

I am thinking the retract command was either not sent or was missed somehow.

I used a touch of hoppes oil from a gun cleaning kit on mine. No problems so far.

Hey @AllenMassey were you carving MDF?

@Zach_Kaplan I was carving soft pine with a .125 two flute straight end mill.

Have you run the same exact job with no changes more than once and gotten the same result?

Not the exact same run. Same project but with some changes,

I recently had this same issue and I assumed it was a software glitch as well (I ran the same project 4 times and only one of the times had the problem.).

I was cutting balsa but had been cutting MDF previously, so maybe it was dust related. I’ll try blowing off the acme screw and see if the problem recurs.

The only common thing between the two failures I saw was the Z axis was cutting a pocket .5 inches deep, then when it was almost done with the pocket it failed to retract the Z before traversing.

I have since done several projects that took over an hour each with no problem, but none of those projects had any cuts deeper than .25 inches.

@JonathanCrellin what software were you using? We are trying to figure out what is the source of this bug. I’m not sure if it is GRBL, Easel, Electronic, or Mechanical.

It’s unusual that we can’t repeat it which makes it harder to diagnose.

Here is a copy of one of my failed projects. The failure occurred when almost done (about 98%) while the end mill was in the outside profile about even with the middle of the circle pocket.


My guess would be thermal expansion of the delrin nut and leadscrew, if there are a lot of z-axis motions. It possible that the expansion could create additional friction and cause some lost steps during Z+ moves. I would try reducing both the Grbl acceleration and max speed settings for the z-axis by half. And try the problem jobs again.

1 Like

I’ve thought about using a teflon dry lube that’s commonly used for mountain bike chains. It dries immediately and leaves a nice coating of super-slick teflon. Have you tried using this stuff on the delrin nuts?

I have not tried it. Is this the same stuff?


That looks like the same stuff. The only thing I’d be worried about is if the liquid base is compatible with plastic, but it says that it’s safe with most plastics, which should include delrin. If you end up trying it, let us know how it works!

I was a gunsmith for many years, and for any moving metal parts that I was not worried would rust, or any parts I did not want dust/dirt/debris to stick to that needed lubrication, we used a molybdenum dry lubricant. It usually has an alcohol base to get the moly lube on the parts that evaporates quickly leaving behind a gray graphite-like coating of moly lube. Also, the moly lube will penetrate into the pores on most metals.

We used the stuff Birchwood Casey made for guns, but any good dry moly lube should work, and it won’t cause dust to collect right where you DON’T want it collecting like oils will.

Hope this helps someone.

@Zach_Kaplan I was using Easel, and I have since cut a bunch of projects in Easel without any problem.