Z-Axis Stepper Motor only works in one direction (Worked fine before)

(Fully loaded X-Carve kit, 1000mm, 24v DC spindle, NEMA 23 Stepper motors, ACME lead screw)

I have made several cuts with my X-Carve with no issues with the NEMA 23 stepper motors. All three axes moved correctly in both directions, until now.

Today I tried to make a cut and while setting up the carve in Easel, the Z-Axis carriage will only move up, it won’t budge downward when I try to nudge it using the on-screen directional controls. (It won’t budge during the homing sequence either) I can hand-crank Acme lead screw and the Z-axis carriage will move smoothly downward (or upward) so there is no physical obstruction. I checked all the wire connections for the entire machine and everything is seated correctly. It works fine moving the carriage upwards with the directional controls, but when I try to move the carriage down I hear the motor try to move, but there’s nothing happening.

I can’t seem to find anything in the forum troubleshooting section that’s similar. Again, the all the motors worked fine a few days ago, nothing has changed since then, the motor will work correctly in one direction just not the other, and the Z-axis carriage moves smoothly in both directions when hand cranked.

I’m at my wits end. Every time I’ve needed this thing in order to complete a commissioned project it fails me somehow and I end up doing the job the old fashioned way. I hate spending good money after bad, if I can’t get this thing to work reliably, I feel like just trashing it and moving on. Any help would be GREATLY appreciated, thank you.

  • Sam

My z failed to move completely, didn’t even hear the motor trying. Diagnosed my case as a Gshield failure by swapping the 4 Z wires and Y wires at the Gshield and attempting to jog Z up and down with the Y axis controls, which worked, while now the Z axis jog commands failed to move Y (be sure to turn off 24v supply power while rewiring everything just in case of stray contact here and there). My diagnosis isn’t entirely proven yet (got a new Gshield last night, plan to install this weekend) but you can do the same test.

If you’re on the stock spindle, might also test jogging with spindle not only off but disconnected to rule out a spindle going bad and mucking up with the digital signals.

Next idea, with a wrench on the pulley nut it can be hard to tell because you have good leverage, you say it manually rotates both ways but is it ‘harder’ to rotate one way than the other? Maybe you need a bit more power to the Z if you can hear the motor trying to move but failing to actually do so. Bump up the jog amount and see what happens and measure the direction that does work, did you get all the distance? If it’s missing steps it might just need a bit more power by twisting the Z potentiometer a tad. I kind of doubt that if it was working and then stopped…seems like unless you had wiring loosening up the ACME screw and delrin nut should only get easier to move with time, not harder…

My last idea is to watch the motor shaft carefully during jog attempts…maybe even make an offcenter dot on it with a Sharpie. Any chance it is turning but the pulley isn’t, in one direction? Might be a loose grub screw or whatever those little things are called…the tiny set screws that hold the pulley on the motor shaft. If it has a slightly canted edge it might ‘bite’ the shaft ok for one direction but slip in the other.

The only other thing I can add to @RichardRemski’s great list is to check your wiring for little loose strands. If a single strand somehow wiggled out somewhere, it could be occasionally shorting to another point or to ground. It may also have broken and fallen out to land somewhere, maybe on the G-shield?

Thank you both for your guidance, I’m going to try your suggestions now. Wish me luck :slight_smile:

I switched the wiring for the Z and X axis motors at the G-shield. Sure enough, the troubles with the Z axis ended and now the X axis can only move to the left and not to the right.

So at least that rules out any mechanical issues with the Z-axis carriage.

I just don’t understand how the motor can receive the power to move in one direction but not the other. I figure it would either work fine in both directions or not at all.

So where does this leave me? Do I need to replace the gshield? Do I need to replace the Arduino? Both?

Seems odd that everything worked fine for ten or so cuts and then all of a sudden stopped working when nothing was changed.

This sounds like the same problem I had when I built my X-Carve a few months back, the exact problem was never found but after replacing the gShield the Z-Axis worked fine.

I would recommend emailing help@ inventables dot com

Yeah, that test should have verified motor and all wiring, only other thing that can go wrong is the G-shield.

I got my replacement very quickly after contacting Inventables support (along with a surprise extra in the package - not saying what as I don’t want to put them on the spot and raise excess expectations, but I was certainly pleased). Hope to install mine later today or tomorrow to see if I’m up and running. Upstairs doing some 3D prints at the moment instead…

The stepper motor driver chip uses four active devices in an H-bridge configuration in order to be able to reverse the direction of the current flowing in the stepper motor coils. If just one of those devices fails then you could have the symptoms you are seeing, namely, the motor works in one direction but not the other.

Thank you so much for your help! It was a malfunctioning gsheild. Inventables sent me a new one over-night.

I installed it and now it moves in all directions again! However, three new problems have crept up (that seem unrelated to the gshield) and frankly I’m done sinking so many hours of productivity getting the machine to work. I’ve posted it for sale for another brave soul to get her working proper. Thus concludes my little excursion into the world of workshop robots.

I’d like to thank you and the many other members who went out of their way to help. It’s a dark and lonely place when you’re suffering techno-hell and no one around you has ever even heard of a CNC, let alone can help you. It’s a real solace to have knowledgeable and friendly people (available on this forum) to help you along. I’ll make sure to let the new owner know where to find help.

  • Sam

This little bit of information from you saved me! I was inspecting the wire connections behind the X stepper and sure enough, I found a fine metal shaving shorting a couple of the screws. This didn’t totally surprise me because it’s set up in my garage shop area. Was getting pretty frustrated before finding that