Z axis was erratic..now I've got bigger problems

The newer laptop is 64 bit. Not sure about version of IDE. I’ll try to check this evening.

Does the newer PC have USB3 ports? We ran into issues with USB serial ports and USB3 ports at work…they sometimes don’t play nice together.

Pretty sure they are USB2

If you see this logo silk screened next to the USB port:

It’s a USB3.0 port. Most newer laptops will either have all USB3.0 ports or a combination of USB2.0 and USB3.0 ports. While they may theoretically be backwards compatible, in my experience with embedded devices and USB serial ports, USB3.0 ports pose a problem. We especially had issues flashing EEPROMs and other type of non-vol memory.

A quick Google search showed that others have had issues with USB3.0 ports and connecting to the Arduino especially with early model USB3.0 hardware so it could be a potential issue.

Just trying to help.

i’ll find out when I get home. While the laptop is newer than the one i originally started out with it is still about 7-8 years old. But you may be on to something. Didn’t mean for my short answer to seem unappreciative if it came across that way. I definitely can use all the help i can get :smiley:

1 Like

You’re good. We’re all here to help and learn from others. I just have run into similar issues and wanted to share because it was the strangest thing at work when it happened and we all thought there is no way it could matter (USB3.0 is technically backwards compatibility) but same PC, same board, some flash file, would not work properly on USB3.0 but USB2.0 zipped right through it. Needless to say, the real solution is a true serial port but very few computers have those anymore, especially laptops.

I’d check all the connections on the Z-Axis stepper. Loose wires can cause some really erratic behavior.

You are right and that was the cause of the z axis taking a dive into my work piece. I found one of the wires had come loose from the terminal block. It was after securing wire that I could not get the Z axis to respond correctly no matter what I tried which led me to trying to reflash the Arduino.

Also, the newer laptop only has USB2 ports. It is running Windows 10 though, where as the older laptop has XP or something close. All seems to be well now although I guess I better hang on to the old laptop in case I have to flash again :slight_smile:

Thanks for all the input.

I would like to know which version of the Arduino IDE you have on the laptop that did load the Inventables fork firmware.

It looks like the one that failed is version 1.6.11. I have seen the 32266 error and wonder if it has something to do with the version of the IDE that’s used.

The version that worked was 1.6.7. I have 1.6.11 on newer laptop that didn’t work.
That could be the problem.

Thanks for looking that up for me.

@Zach_Kaplan anyone in your company seen any problems with different versions of the Arduino IDE in regards to compiling the Inventables fork of grbl?

Is your Arduino a genuine or clone, I am working with microcontrollers for ten years now and have seen very weird behaviour with clones. They seem to work perfect and then you hit a roadblock of one function that is missing. Same for the cheap stepper boards (US8 for 4) who do seem to have a prescaler but no microsteps. The original Pololu 8825 boards run a lot smoother. I decided to ban the clones completely from my projects as they cost too much time.

My Lenovo ThinkCentre has USB 3.0 ports and had no issus upgrading Grbl

1 Like

I have the original Arduino that came from Inventables

@StanPhillips can you please try contacting our help team at 312-775-7009 or via email here. They can work with you to figure out a solution.


I got it straightened out. We were just continuing the discussion on why it would not work with one of my laptops.

1 Like

@StanPhillips Thanks for bringing up this possible solution! We have had multiple users report this problem about the Inventables grbl fork being too large, and we have even encountered it ourselves while remoting into customers’ computers to help them connect their machines.

This is the first time someone has suggested that it may be the IDE that’s causing the problem, not the fork itself. Can you please tell me about the two computers you’re using, too? It would help to know what kind of computers they are, what operating systems they use, etc.

@LarryM Can you please confirm that the 1.6.7 version of the IDE worked for you? Or did you do something else to get the correct Inventables fork installed? We have a few workarounds in place to deal with this “too large” grbl fork, but if we could determine the root of the problem this would help immensely. I see @JustinBusby mentioned the USB ports, so I’m wondering if you can tell whether or not this contributed to your solution?

@Zach_Kaplan CS and Dev have known about this issue for a few weeks. We’ve helped customers work around it by using an older release of the Inventables fork, but obviously it’s not ideal. It’s just the only thing we’ve been able to do to get people using their machines. This IDE version a different solution that we’ve not considered. Thanks to @EricDobroveanu for sharing this thread with us! He is working on some tests to figure out if this might be the cause.

1 Like

I have Arduino IDE 1.6.11 and 1.6.5 installed.

Flashing grbl with 1.6.5 shows the following file size: Sketch uses 29,038 bytes (90%) of program storage space.

while using 1.6.11 has: Sketch uses 30,852 bytes (95%) of program storage space.

It definitely seems like newer versions of the arduino ide are using up more of the onboard storage.

1 Like

I will try to get you that info as soon as possible. Thanks for the support!!

OK, laptop that would not flash Arduino properly:
Dell Inspiron, Pentium dual core 2.2ghz 64 bit processor. 3Gig ram. Windows10, USB2.0s
Arduino ide 1.6.12, Easel 2.2, USG 2.0
Laptop that flashed properly:
Acer dual CPU 1.86GHz. 32bit processor. # Gig ram, Win Vista(about 200 Win updates behind) USB2.0s
Arduino IDE 1.6.7. Easel 2.2, USG 2.0

If there is some other info you need let me know and I will try to find it.
By the way, LarryM is reallywho connected with the differences between versions of IDE. I Just tried my older laptop as a semi last resort :slight_smile: