Z-Axis zero depth problem

Have a problem with the z - axis depth and yes I did do a search and tried everything suggested. Hopefully someone else had this same problem and can help me. Have a project the is setup to cut at .157 depth. I have a brass block that’s .81 thick and I hooked up a led to light up when the bit touches the brass. I then click on carve and on the right hand side it allows you to move the X Y Z and I put in the box .81 and click on the down Z axis botton which should put me a zero on the project but instead the bit goes right thru the project (breaking the Bit). I then start over but this time I cut the .81 in half to .405 and click the down botton and it stop at zero on the project. When I start the cut the bit cuts twice the depth of .157 and I have to reduce the drawing to .07 for it to cut the right depth. I tried this in MM and the same things. I did check the shut on the circuit board and it is correct. When I use the real measurement for x and y the perfect I say 1 inch and it moves 1 inch. Any Idea’s why this is happening

In the machine set up did you select the correct X screw option?

So when you command Z to lift say 1" does it move 2"?
If yes, edit your $102= to 1/2 of current value, reset controller and try again.

You could also change your micro step setting to half current level. (Select 1/4 if 1/2 is set)


Yes I actually tried both options. good thought thanks

your correct when I enter .81 it goes up to 1.62 so I had to reduce .81 to .405. but X and Y work perfect.

So where do I go to enter these codes is it a file on my PC.

  • Open Easel and press CTRL+SHIFT+D to open Machine Inspector (also available from Easel meny)
  • In the Console window, type $$ and press Enter, all GRBL values will start to list up. The $102 value is what you need to change.
  • To change,in Console simply type $102=new value and press Enter.
  • Reset controller and see if all is good.

First thank you so much for taking the time to help me. At least now I know where to enter G-Codes.

My $122=50.00 was what the system showed
I change it to $122=100.00 entered got out and went back into it did a $$ and it showed the change.

As for the z -axis I entered 1-inch and the unit went up 2 inches same as in the $122=50.00

I then changed it to $122=25.00 and tried again and the same thing.
any thoughts.


Leave $122 where it was for now.
It’s $102 you want to change.

Aloha Everyone,

Thanks for everyone’s help it looks like the solution was $102=94.488 it was $102=188.976 and I reduced it in half and that worked I don’t know why after it was setting for 2 months that it would chaged but this seem to work.


@GeorgeHenry Possibly a misplaced microstepping jumper on a gshield?

$102 is indeed the parameter to change, not $122 as I incorrectly specified - my bad :slight_smile: Edited my post.

No problem you showed me how to enter g-codes learned something new. Thanks