Z burying the bit on startup after Z-upgrade [Solved, $102 recalibrated]

Hey! Just installed the upgraded z axis/belt kits and everything went smoothly, or so I thought. Now, when I go to run a test piece, the z begins to lower and continues until the collet nut on the spindle makes contact with the material I am cutting. After installing the upgrade components, I followed the instructions to modify the settings in easel. I can’t help but think this is something simple that I over looked or just didn’t understand as I am still new to this. Any ideas?

You will need to check your $=102 setting. I am not sure what the setting is for the new upgrade.

1 Like

By chance did you happen to go through the Machine Setup at any time AFTER adjusting the $102?

More info on the issue that seems to keep on creeping up on many of the users of the new Z Axis upgrade: Using Easel?? Here's WHY your CNC just crashed 💥 - YouTube

Basically there are two things to consider when altering the Z-mechanism:

  • Direction of travel (might be reversed due to drive geomtery)
  • Re-calibrating the step/mm value for Z (GBRL parameter $102)

If direction of travel after upgrade is the same, no need to address that further.
If direction of travel is reversed the quickest solution is to swap around the polarity if either the wire A-pair OR wire B-pair. Either is good.

If actual travel do not equal commanded jog travel then a recalculation for $102 is required.
What is your current $102 value and how far do the Z jog when you command 1/2"?
To find your GRBL parameter open Easel Machine Inspector (CTRL+SHIFT+D) and type $$ in Console followed by Enter.

Report back and we can do/show the math involved, it is not that hard but can be confusing for new CNC-operators :slight_smile:

Problem, solved! It was in fact the $102 value. It’s odd though. After installing the upgrades, I modified the vale’s per the instructions and did not run the “Machine Setup” again. When I checked the values this morning, the other values remained set to those specified in the specs, but the $102 had reverted back. I don’t think I skipped it during the process but maybe so. Regardless the issue is fixed. Thank you guys for the replies. :metal:t2: