Inventables Community Forum

Z depth wrong and gets higheer

First cut. board is 5/16". text to be cut is script from pro. Depth set to 3/16". Bit set down to touch wood before start cut.
First letter is barely 1/16",Onto 2nd letter the bit stops at 1/8" above wood and continues to carve that letter but never lower than 1/8" above the wood. I want a 3/16" deep carve but the 1st letter barely shows and next is carved out of air.
No idea what to try next anymore.

Welcome to the forum Alex,
How are you setting you Z axis?
Are you using a Z probe or doing it manually?
What bit are you using?

Looks like he is describing manually with “touching down the bit”? Although if it was a z-offset error it should be consistent, not changing. That sounds more mechanical (loose belt, lost steps, etc) assuming he is running all the letters as a single job without resetting the zeros between each one?

1 Like

No belts, screw shaft only for all axis. No Z probe, just touch surface.XY seem to be ok. Z never gets to depth and next letter 1/8 to 1/4" above surface carving. I stop after I see that. First cut just scratches the surface, nit the3/16" I desire. I have tried many machine configurations with always th same results.

Also Firefox browser not friendly this interface. New Explorer worked

so this isn’t a stock x-carve? Is this a cnc4newbies? are you using an x-controller or something else?

GRBL controller and I tried the X-controller settings, both the same way.
It seems like a calibration for Z axis only to fix this …but different heights for next letter?
I have tried UGS platform and GRBL Candle to try a carve and worked OK, but can only carve from files and not able to create files…


What is your current micro step setting and $102 value?
What voltage do you supply your stepper drivers with?
Do a 20mm jog = 20mm motion?

I recon you are experiencing missed steps.

$102 was 188.96, changed it to 800.000 to be the same as X & Y is 800. (made no difference)
PSU is 24 volts
I measure 10mm jog as 10 mm
I ahead of you there…
I ran the job import g-code and still the same depth results!
Ahhhh!
Can I read the setting in easel?

Found code in machine inspector
GRBL Ver 1.1f

Missing steps would have been created by Easel???
Other simple software work ok.

That makes no sense if 188.96 gave you correct distance to begin with.

Can you include the gcode / or share the Easel file?

122 ADDRESS.zip (28.3 KB) Alex G-Code3020 Machine.txt (1.8 KB)
I gave it another shot today, no difference.
I changed $112 100 to 200. Z is faster now…only.
I would like to see something work, I may sell this machine as I can’t seem to use it at all with Easel and nothing much out there is 10 to 20 times the cost of the machine to see if it works.
I am mulling the idea of getting a ‘real’ carving machine. I am currently using a laser cnc, but would like to add wood cnc.

I have come to the conclusion that the control board Z portion is faulty. Have contacted supplier for replacement or refund. Tried different $ values with no changes, tried other drivers and worse. (probably ruined 2 good drivers in the process)