Z Probe and Z axis cutting too deep

I am just finished installing and during calibration, I am having a Z axis issue I think When I use the Z probe, zero out at home position and then begin a cut … the bit lowers down on material too far and cuts as it moves from home position to the first path. Then it seems like its cutting a bit deeper than programmed.

I then did a manual Z axis with the paper trick … and while the bit stays above the material from the home to the first path, the cut seems to get a little deeper with each pass. Not a extreme amount but by the end the cut there’s a noticeable difference.

Both issues lead me to believe my Z needs calibrating… but from all the threads I’ve read, I can’t come up with the answer.

By the way I am using the ACME screw for Z…

I chose the M8 and had the same issue. Changed to acme and it is running great. Also make sure you select raise bit after setting your Z in setup before you start your cut.

I have a total of 4 hours with this machine so if I’m wrong I would hope someone would correct me.

Yes make sure to select the proper Z axis type. Rerun machine setup just to make sure. It changes the steps/mm value which affects cutting depth. Search the forum for stepper calibration procedures to really dial it in.

That is where I started … .59in or 15mm … and that is what was defaulted by inventables…

The probing process seems to work fine, but once I start the spindle and push CARVE … it comes down into the wood at home position and then moves to first path.

PHIL … YES for all three. I did come across your stepper calibration excel sheet and have not had the chance to accurately measure the steps which will be my next thing tonight, assuming Easel will be back online.

1 Like


1 Like

Things seemed to maybe have rectified itself after Easel crashed and reset today. So I am thinking after I changed to the Acme screw for Z it didn’t save… so when I reset again tonight and did a test carve it seems to be accurate. Is there any place in grbl to see which one is selected other than the $102 =188.976??

I did calibration and all X,Y, and Z are accurate … z probe is exactly .59in and set as such.

I will do first official cut this weekend.

1 Like

Well, I am now having the issue show up again. I’ve cut a simple design in a pine board with decent success. Put down another board to cut it a second time … and DISASTER. After cutting four letters you can definitely see that each letter got a little deeper … (I’d like to post a picture but unsure how?)

I re-calibrated the z axis … by measuring that when you jog 1 inch it actually jogs 1 inch … and I would say it is very close to perfect.

So I am at a loss … can not figure out why it works sometimes. Could it be something with a loss of steps with speed of cut or material being cut?

Check the pulley set screws for the Z-Axis.

Can you remind me what set screws your speaking of…

The little grub screw that attaches the pulley to the acme threaded rod…I believe the one on your motor does not have a set/grub screw.

Yikes I think I am actually missing one of the two set screws. Can anyone confirm there should be 2? And secondly, if I am missing one how do I find the right size??

There should be 2. And I believe they are M3 size. I replaced all of mine with a M3 10mm socket head screw and used blue loctite on them.

Can I assume this is an online purchase or will the big box or local Ace carry them?

Actually found the lock nuts holding the motor worked themselves loose also… can/should I blue loctite those also?

yes…loctite the others…I think I bought them from Amazon…the screws may be in the big box store.

If it’s a nylock nut, loctite shouldn’t need to be used is what I thought. The nylon part acts just like loctite I believe.

I replaced my set screws with M3 x 8mm patch screws from McMaster-Carr and they were a tad long and were hitting the bearing retaining screws. I changed the bearing screws to be shorter (6mm instead of 8mm) so they don’t interfere.

McMaster is a good online source and, for me, is 1 day ground shipping because they ship from Atlanta for me.

1 Like

@JustinBusby - Yes, no loctite needed on nylock nuts…and they should not have come loose either :slight_smile:

I just tried to find the exact size on the installation instructions and even the CAD explode view and can not find size. M3 but what length … Does your 10mm socket head get in the way, those seem rather long to me.

My z-Axis is no longer standard, so they might be too long for yours. I don’t remember when I swapped out the set screws…

This was what I had changed to at first…