Z-probe not properly measuring depth

I’m new to the X-carve and looking for some information.

I’ve been having issues getting the 60º bit to look like the easel 3D representation. The corners are blown out on what should be sharp corners. I’ve seen this issue posted on another thread. I posted there too and all is quiet. I was looking at the paths closely and noticed that the 3D representation goes a little deeper than the path line (blue line). The bit being used is from inventables.

Taking all this into account, I decided to measure the depth on the actual cut. It is about .3 mil (or so deeper than what was specified in easel. The setting was for .8 mil and the depth after cutting was 1.1 mil. Wood is flat and level and the depth is consistent from on end of the wood piece to the next.

Is the z-probe I’m using not milled correctly? Can I compensate the difference somewhere in the easel settings? Should I not use the z-probe?

Thanks in advance for any help!

I have the same problem.

In the machine setup when it asks to set up the z-probe there is an advanced area. You can set the thickness of the brass disc in the advanced portion. I would include a screenshot but I am on my Linux box right now and can’t get to that machine setup.

I measured mine with calipers and it measured the same as the thickness in advanced settings, so I just fudged the number to get the correct depth.

Is it possible there is a bug here @JeffTalbot ?

you might also want to check your calibration of the machine.

If you move your Z-Axis 10mm down did it travel 10mm or was it 9.7mm or 10.3mm etc. etc.

if you machine is out of calibration it will also cause this type of error.

1 Like

Probe incorrect (probe feed too fast or puck thickness incorrect)
Steps per MM (Z) incorrect (dial/test indicator check)
Material thickness incorrect (wrong dim / warp)
Bed surface issue (not flat / even)
Assembly issue (something loose)

Things that come to mind to check

All of which we already checked on ours.

so your saying that if you move the machine 10mm in the z axis it moves exactly 10mm but when you cut after zero it cuts 10.3mm?

your measurement of the Z probe is accurate and your depth of Z is accurate and you have checked for any loose parts on the machine and your tram, (bed level). then you have a problem with the G-Code that is generated.

please post the G-code so that it can be viewed for the error.

1 Like

It was not one carve it was all of them. As mentioned above we fixed it by fudging the thickness of the puck so it really isn’t an issue for us anymore.

If you probe and then go to Z0, is the bit just touching the surface?

shouldn’t have to compensate. may come back and bite ya down the road.

if all else looks good then likely something up with whichever method to create the code or the post.

Thank you all for the suggestions. After running several tests I determined that the distance was equally inaccurate at different depths by .2 mil. Agreeing with DebbieLee until I hear more. I adjusted the thickness of the puck from actual thickness (14.95) to 14.85 as the depth was .1 mil deeper at several different depths after setting the thickness to actual first then testing. I also noted that the puck is not perfectly flat. I’ll be aiming for the exact center when calibrating the z. Another side note: I tried zeroing the z to the material and the results were much closer to actual thickness settings for the disk. Between getting the right z probe thickness set and fudging the numbers (as DebbieLee says) The x-carve is only .05mil off. I;m not sure if the calipers are accurate enough to make it perfect but I feel a lot better than being .3 mil off. Thanks for the help and guidance. Looking forward to sharing some ideas and projects soon.


We did some testing here and weren’t able to replicate the issue on our X-Carve using Easel.


We are going to do some more investigation into this.

@DebbieLee and @RyanJohnson: If you have time, could you tell me exactly what type of material, dimensions (especially thickness), and what type of bit and bit sizes you were using when you noticed a depth of cut mismatch using the Z Probe? If it was multiple materials or bits, please list as many as you can remember.


Hi Jeff,
I first noticed it on a piece of one inch stock. I carved a small pattern in walnut, cherry, and ash using the the 60º bit (which I don’t use anymore). I also tried it with the 90º bit. It was subtle but I noticed the thin lines where too thick (the bit going too deep) so I tried some tests using 1/2 birch plywood and a 1/8 straight cut bit. Using calipers and measuring at several points of the flat depth cut I discovered the z was off.