Z-Probe not working correctly

I am no longer asked to Z-Probe and cannot figure out how to get it back to working. This happenned in the middle of a bunch of repetitive carves and after n upgrade. X-carve has told me to set it up, but I am never asked to set it up

Have you checked it is set in settings?

When you’re in Easel, go to Machine and then to Set Up Your Machine. That will take you through the steps of setting up your machine.
Good Luck

@WilliamFromm if your still having issues feel free to reach out to help@inventables.com!

Hi I have a similar problem set the z stop router goes up Then when I start to carve
The z does not go down far enough