Zeroing universal gcode sender?

I’m trying to run a new string of code for a cut but every time I do the xcarve offsets about 60mm+ on the y and 60mm+ on the x axis, then starts the cut. I’ve tried resetting zero in universal gcode and ensuring that my cad is centered in fusion 360, but it keeps happening. Any idea why that might be?

(T1 D=6.35 CR=0.381 - ZMIN=4.776 - bullnose end mill)
G90 G94

T1 M6
S6281 M3
G0 X57.549 Y74.668
G1 Z39.9 F500
X57.795 F875
X58.173 Y74.582
X58.351 Y74.557
X58.568 Y74.543
X58.831 Y74.548
X59.148 Y74.579
X60.114 Y74.753
X61.081 Y74.924
X62.055 Y75.042
X63.033 Y75.124
X64.013 Y75.18
X64.994 Y75.219
X65.975 Y75.245
X66.956 Y75.264
X67.938 Y75.276
X68.919 Y75.285
X69.901 Y75.291
X70.882 Y75.295
X72.845 Y75.299
X73.827 Y75.3
X74.806 Y75.242
X75.779 Y75.112
X76.735 Y74.888
X77.661 Y74.562
X78.548 Y74.143
X79.376 Y73.615
X80.134 Y72.992
X80.816 Y72.286
X81.394 Y71.493
X81.872 Y70.635
X82.24 Y69.726
X82.505 Y68.78
X82.69 Y67.817
X82.819 Y66.844
X82.908 Y65.866
X82.969 Y64.886
X83.011 Y63.906
X83.04 Y62.925
X83.06 Y61.943
X83.074 Y60.962
X83.083 Y59.981
X83.089 Y58.999
X83.094 Y58.018
X83.099 Y56.055
X83.102 Y53.11
X83.103 Y46.239
X83.102 Y16.794
X83.075 Y15.813
X83.023 Y14.833
X82.908 Y13.858
X82.74 Y12.891
X82.494 Y11.941
X82.182 Y11.01
X81.79 Y10.11
X81.329 Y9.244
X80.791 Y8.423
X80.186 Y7.649
X79.514 Y6.934
X78.783 Y6.279
X77.996 Y5.693
X77.139 Y5.215
X76.218 Y4.875
X75.266 Y4.635
X74.299 Y4.468
X73.324 Y4.352
X72.346 Y4.272
X71.366 Y4.217
X70.385 Y4.179
X69.404 Y4.153
X68.423 Y4.136
X67.441 Y4.123
X66.46 Y4.115
X65.478 Y4.109
X64.989 Y4.145
X64.04 Y4.397
X63.208 Y4.916
X62.486 Y5.582
X61.852 Y6.331
X61.266 Y7.119
X60.715 Y7.931
X60.188 Y8.759

Check your file setup and make sure you don’t have any offset values entered.
I am not sure what it is called in 360, but I know other people have had a similar issue.

Fusion 360.

I am not sure either, i keep combing over the cam portion but im not seeing it. Any idea if its in the CAM or the CAD side?

When you say “my origin”, what do you mean? Ive positioned the work piece in the center of the planes.

Is it this piece of gcode that’s moving the machine? I’m now noticing it on other files I’ve made that didn’t have this problem in the past. I watched 2 fusion 360 Pinewood derby videos. I saw how he set the work piece zero and tried that but still no luck.

I used the fusion 360 post processor. I’m not certain I understand what you mean by modeling the stock. As for the origin I always set it to the center and tip of the stock, then eye ball it and do the same with zeroing the bit.

That worked thank you!

1 Like