3D Carving with the Carvey

When I imported an STL and processed it, everything seemed fine. When I went to run it, I got the error message: “There are no objects in your design that can be carved with your current settings”.

I knew this was false so I exported the gcode and imported it into a new Easel project. When I ran it, it worked. Is there anything I’m doing wrong with setting up the file? Having to export/import gcode for each roughing & finishing pass of everything I’d like to cut seems excessive, and I’d like a better workaround.

(Also, the 3D interface doesn’t show the area where the smart clamp is, but I moved my piece to be far out of the way of the smart clamp.)

1 Like

Hi Eileen, thanks for the feedback. We are still working on Carvey compatibility - as you saw there are a couple issues with the smart clamp we have to sort out first. Until then, the export/import is the best way to use 3D on a Carvey machine. I will update this post when we have the issues resolved.

2 Likes

Sure would be great if 3D worked as well as everyone else says it does. I have tried everything. Getting the same error as Eileen. I used Eileens method of exporting gcode and importing it into a new easel project and the import failed here is the screen cap…


Help! I was really excited after all these years to finally have 3D capability without third party processing.

I would prefer not to have to export the gcode from easel then re import it into easel and just have the STl import function work. What am I doing wrong?

This is directly affecting my decision to purchase an X-Carve Pro. I was all set to buy a ShopBot then when 3D carving came out for easel I started looking at the PRO again. There is no way I am doing that if I have to use Easel and Pro together.

1 Like

As a point to note here, the X-Carve Pro is a grbl based CNC and does not Require Easel to operate it. It can use a variety of other opensource gcode senders like USG, OpenBuilds Control, Picsender, Gsender, or even Vectric’s Vtransfer. With that you can also use any number of CAD/CAM software beyond Easel as well such as Fusion360, the Vectric Suite, the Carveco Suite, Solidworks CAM, MeshCAM, EstlCAM, and more.

That G28 command error only occurs when a Carvey machine type is selected, ALL other machine types do not include the G28 command within the Gcode file when it is originally downloaded and thus the fault only occurs for Carvey users. . The X-Carve Pro does not suffer this fault.

Thanks for the info Seth.

1 Like

I’m getting the same G28 command error with a Carvey. Is there away to work around this?

1 Like

Just a guess here, if you open the gcode file with a text editor and delete that line… but i don’t have a carvey to verify, so at your own risk. If it starts the carve fine, it should be good throughout

1 Like

Yep, this is what works for me! Note that it’ll also throw an error for some stuff in the footer of the file (G50 and G53 I think). I just delete whatever it tells me to until it’ll run.

1 Like