A better Fusion360 - GRBL PostProcessor

Michael,
Please read all of my comments on my last reply.
I’m trying to help.

G28.1 does not set work zero. Why do you think that it is?

My work zero is ALWAYS below MACHINE Z-15.

Don’t use Strooom’s post. I don’t know why you are. Use default Grbl.
If you need custom motions, I can help edit a custom post.

Michael - you havent grasped how it all works yet, that is okay :slight_smile:
We have been there.

G28/G30 require a fixed machine zero (typically homing switches)
G28/G30 are user-defined parking spots and can be placed anywhere within the work range of the machine.

Home position = work zero and can also be anywhere within the range of the machine. Not in any way related to G28/G30

A CNC is commanded in either absolute mode or incremental mode.
Read more about the difference here - https://www.cnccookbook.com/g91-g90-g-code-cnc-absolute-incremental-programming/

In absolute mode (G90) a Z-15 command will place the the bit -15 units below Z highest point, (Machine Z zero) while incremental (G91) Z-15 command will lower the bit -15 units below its current position - where ever that was.

Absolute mode is machine zero dependant.

1 Like

Anything I should be aware of? I am using Strooom post and it works well for me. I like the post-carve parking spot defineable in CAM. I also have Larry’s F360 post but havent machined much since loading it.

Hey @HaldorLonningdal. You have homing switches. Not an issue for you.

Gotcha.

Wow - this is the best explaination I ever saw. Now it is clear to me.

The machine zero point is defined with the limit switches and it is the highest z value. I thought it is always lower z value or the work area z point.

Now it is clear why the Z-15 was sent.

I appreciate that - thank you very much Haldor.

And Neil you are right. I used the standard GRBL that came with Fusion and this is working now for me.

With a small issue. So the fact that my China cheese mill does not have limit switches, I move the tool to the material work area zero and set all axis to zero inclusive G28.1 by hand. If I start the generated fusion g-code, it is moving the xy position to the start point for the first milling - without moving the tool. So I have to add manually G0 Z2 to lift the tool for 2 mm and start the xy movement afterwards. I do not know if I can customize this ülifting automaticly, because this is in the preprocessors section of the to be milled bag.
For the second bag in the sequence, the tool is lifted. This is switched on in the fusion setup for fast positioning (lift tool 2mm). Not sure why this is not working for the first section in the setup.

But thank you all for helping here. Now I can work with the mill…

Regards Michael

Can you share your gcode file?

I’m still confused how you’re using G28

Hello Neil,

This is the start of my g-code:

————————————
%
(ReichertBlende5)
(T1 D=3 CR=0 - ZMIN=-5.2 - flat end mill)
G90 G94
G17
G21
G28 G91 Z0
G90
(2D-Kontur1)
M9
T1 M6
G0 Z2 <<<<<<<<<< this was inserted by hand
S600 M3
G54
G0 X35.6 Y53.85
Z7
Z4
G1 Z1.2 F80
Z0.1
G18 G2 X35.9 Z-0.2 I0.3
G1 X36.2 F150

———————————-

The G28.1 was set manually after positioning the tool to my working space.

Regards Michael

Me 2 :slightly_smiling_face:

Because the G28.1 is setting the new zero point which is used by G28.

I saw this on YouTube video of someone that was using the same mill.

If I do not set the G28.1 then the G28 command is moving the tool to outer space.

Regards Michael

Use a post processor that dont generate G28 :slight_smile:
Or delete the G28 reference in the code.

A fixed reference point is a requirement for G28/G30 or any WCS offset to work. Without that it’s a lottery at best :slight_smile:

Ohh yes - that was the trick. I switched of the G28 in the postprocessor options of GRBL and now I just lift the tool manually after zero it and then it moves to the start point, without relocate it to the G28 point.

Thank you. All problems solved and neither G28 nor G28.1 anymore. Perfect.

Michael

1 Like