Abort button not working

Hi, the abort button in Easel next to the pause button is not responsive, meaning that the job continues. The pause button does work. The abort button used to work. ?


Also sometimes its takes 30 to 45 seconds to clear the memory buffer on the Arduino

Rebooting computer and x-carve (power disconnected for a minute) did not resolve the issue. However, the problem is resolved.

I did not mention that the abort button was not responsive on an imported g-code project. I tried running a project drawn up in Easel and the abort button became functional again. I re-imported the g-code project and the abort button was still functional. I restarted computer and x-carve again and imported the g-code project first thing and the abort button still worked. I will post additional information I learn something but until then, the issue seems to be resolved.

Thank you both for the reply.


1 Like

Oh. I only use UGS

1 Like

I’m currently having this same issue of the abort button not working. I’m in the middle of a few hour job where the bit just broke and the machine is just going around in air. I’d like to abort, add a new bit and start from where I just left off, but without being able to abort, I can’t find x,y home position unless i let the job complete I guess with the broken bit in the machine. Anyone have a solution for this?

I don’t think I’ve heard of this problem before, but if it happens again please be sure to click “Something went wrong” when it finishes or when you shut off the machine, and then click “Get help from Inventables” and send an error report. The diagnostic info that Easel sends can help us figure out what happened.

I did that earlier. The same just happened to me again. I’m here again letting the machine do air cuts so I don’t lose my home position. This has to be fixed. One user said it only happens when importing g code. I imported from vcarve, if that makes any difference.

I’m using a 0.8 mm bit. But that had nothing to do with the point that the abort won’t work.

This has been days and the abort button is still not working for me. I imported g code from v carve, and i can’t cancel the job, therefore have no way to go back home without letting the job complete with a broken bit. The broken bit is not the issue. My workflow is fine when the x button is working. I just want that working again, if they ever address this problem.

I dealt with someone from the error report page, that suggested I could use limit switches, but there are many things I could do. I just want the buttons working as they should. And I updated my easel version as he suggested, but that also did not change the issue.

Have you tried the solution that the original poster used?

I have, but I may be confused as to what he’s suggesting.

My understanding of his process was to start up Easel, design and run a project (could be just a air cut) with Easel let it finish, then run it again and see if the abort button works.

If that works, then import your G-code, run that and see if the abort button works.

Hi folks, we’ve identified the cause & have a fix on the way.

This should be working now. If you’ve been having the problem, please reload any open Easel browser tabs before starting your next carve.

Techy details: The problem stemmed from some carve-related information that we were saving to the browser’s local storage for the duration of the carve. Browser local storage is unreliable—for example, it’s subject to disk space limitations, privacy settings, etc, and also is not shared between different browsers (e.g. between Firefox and Chrome)—so we have to be pretty defensive when using it & generally try to avoid it for important features. Easel reads back some of this data when it tries to stop a carve in progress. Unfortunately a recent change made this data retrieval not as defensive as it needed to be, and if the data couldn’t be read it would cause an error and prevent Easel from sending the stop command.

I’m sorry for the frustration & wasted time this caused. Thanks to @TomP and others who sent error reports that helped us get to the bottom of it.

1 Like

Rodovich, that’s great customer service. Thanks for addressing the issue so quickly.

Additionally, I know now how to send an error report and that they do not go unnoticed on your end.