Advise and help please

Hi: Could I ask for some Advise on my X Carve? I only had this for a few months now but here is what I am having problems with. First when I set it up it seemed everything was working great. It went to homing and all my limit switches seem to work. So I loaded a complex G Code file using V carve Pro And have post prosser using Easel. It would,not load so I called Griffin and he recommended I used a universal G code sender. I ended up purchasing Pic Laser from picengrave. Made sure it was on Spindle loaded g code ok it started out great carving about 30% in it started to rise from the wood piece but was not carving on the wood but keeping its course. I stoped the carve looked at the G code everything seemed ok but I am not sure what I should be looking for. Now my X Carve will not go back to home if I push SH it just moves the Z Axile a little at a time but won,t home into position. I even put new limits on. Series of problems. I have a carvy and never had any issues with it or loading G code files into it. Any help would be greatly appreciated. Thanks

I have had this very same or similar issue. The solution that I came up with was multi-part. I first checked
for polylines and arc’s that may have not been connected. I checked for duplicates. Basically I cleaned up the design and created new G-Code. You may also want to check to make sure that the g code is infact set for machining in the right direction, also make sure that the g code sender is interpreting correctly because some of them do not interpret arcs. Check feeds and speeds as well, fast is not always best

I don’t know that this will fix the issue but easel is not the correct post processor for picsender. I forget the one I use because it’s always selected. I only use picsender. Search this forum for picsender processor.

I just looked, I use vectric xcarve inch post processor. My processor issues in the past wouldn’t run 30% of a job. It would quit in the first 5 seconds.

My z issues in the past were slipping pulley set screws, incorrect pot current and setting my Z too fast in tool settings. My 3D carivings would dig too deep halfway into a job or would begin to lift.

Hi: I read your comment. It sure makes a lot of since abut the arc’s may not been connected. And also the machinging going in the correct direction. But why would it start out great for the first 30% then go off in other direction? That’s were ham confused at. Can you please tell me how to check for correct direction on the file or G code. Are you saying like positive or negative feed? Iyou might have it correct with the arc’s not being saved. Thank you for you time. Any other response would be appreciated.

Robert I read most all your post. I know you are sure what your saying. I don’t even have a one job put on this machine. I am pretty sure I have the correct feed and speed dialed in. But I am going off a scale I use on my carver machine. Is there a certain way to checked for pulley slipping? I will replace them if you think that’s what it is but it still doesn’t explain the homing issue and why it quit working with my limits I have on it. Any other advise would be great and thank you for your time of trying to resolve my issue.

Hi: Dan I am sorry guess I did not explain myself well enough. I use Vectric V Carve pro and Easel as the Post pressor.
I will however have to look up the post pressor for pic sender. Should I just google that or do you have a site to go to? Thanks for your time

X carve is what my issue are with and yes one works off grlb and the other andiron ? Something like that not sure about the correct spelling. But my issue are with the X Carve 1000
Thanks again maybe you’ll figure this out for me :slight_smile:

I would check the wiring on the Z.

I OHM Out the limits and it was great when I push on SH to go back my Z just moves really slow to the top to hit the limit but then it stops. Also if I Home it manually it works ok. Auto is were I seem to have the problem. Thanks for your reply and help.


Please send your file to my email: I will need the actual design file and your gcode

Is this the Xcontroller?

Check your internal ribbon cables and make sure they are fully seated, That might be causing your switch issue.

It wouldn’t explain the carve issue but maybe the homing issue.

Tracy Ranson: Well I got my Homing issue fixed it was the settings in my machine set up somehow it got missed up. But John from Inventables help me and got it fixed. As far as the G Code going off I will send it to you but it won’t be until tomorrow I have to go to work I am on eastern Time from Ohio. But I do want to thank you and all the community of great people we have that are willing to help. Please let me know you received it be in the morning sometime then just get back to me. My email is
Best Regards: Tim Monfort

Justin: Thank you for your advise I got it fixed it was in my internal settings. Somehow it got erased trying to figure out how but it is fixed with the homing and limits. But again great forum and great bunch of people on here that is willing to help thank you. Best: Tim Monfort

Robert Thank you I will definitely check everything out. I was able to fix my issue with the homing. It was in my file settings on my machine. But thank you for your great advise and I will follow up with the advise you given me. Best Regards: Tim Monfort