After E Stop

After a bit change my z probe didn’t stop the probe on contact, and I hit the E Stop. I reset everything and went on my way. Relocating X and Y were not a problem and the probe worked as it should, but cuts were off by about 1/4 of an inch and ruined the piece.

I reset the com port and reloaded the gcode and tried again on a new piece. It cut clear off the board, wasn’t even close. I let it finish and returned to zero, but it was off about 1/4 inch in Y. The X seemed OK. I’ve used the panic button before but never had an issue after restarting things. I’m using Picsender as my gcode sender.

Any ideas would be welcome. Thanks in advance for your help.

Do you have homing switches installed?

No homing switches. I completely reconstructed my cut file and redid all my tool paths. Rebooted my computer and restarted my xcontroller. Same thing.

I performed an air cut starting from the same x, y zero and it retraced the same incorrect cut as before. I looked for a mistaken offset in my file but their us none. I checked the calibration steps against a mm ruler, and it’s off a tiny, tiny amount, but nothing like what I’m seeing.

Is it possible that hitting the EStop would discombobulate things this badly and need a reflash?


If you add them you’ll have a repeatable reference point for X&Y, within the precision of your switches. Work zero, parking spots like G28/G30 are permanently (*) stored as offsets from machine reference spot. ( * - until reassigned)

Its possible you are loosing steps, if so there is some settings or locations on your machine that give you increased resistance.

Can you share the project?

1 Like

I have found the problem. It was a measurement problem with my work piece. Mismeasured the actual piece from the beginning. Of all the bone headed things! The machine is fine, I am not.

1 Like