After Z-Probe carve starts about 1/2 higher than material

After of year of sitting I re-setup my x-carve and on the first carve test, the machine goes thru its routine, goes thru x-probe on the material. When you start the carve all seems fine, router goes into position (which from all indications) is correct but it starts the carve about 1/2" above material (maybe a bit less), running thru the program like a dry run LOL.

Any indeas? I have reconfig the machine more times than I care.

Thanks in advance


When you do the machine setup are you selecting the correct Year Model of X-Carve? There is the Pre-Nov 2020 model and the Post-Nov 2020
Selecting the incorrect Year model will cause Easel to push the incorrect Calibration values to the CNC. One of these values effecting the calibration of the Z axis.
I suggest determining which Year model you have and redoing this setup selecting the correct one.

And also ensuring the correct z Probe thickness is used within Easel.
To check this go to Machine>Edit Machine and there at the lower left is the option to configure the probe.

And also IF this is the newest version of X-Carve, Ensure the Z axis assembly is actually low enough to reach the workpiece at all…

Thx Seth, I have it setup for the older machine, I can get it to cut not using the probe but setting work height to the wood surface. Now I am looking for a 1/2 depth cut with a 1/4 bit I am getting a 1/16 overall cut. I first set this up in Vectric software that is what started this, now I have created it using easel and this is the result no going to depth. A simple rectangle pocket and can’t seem to figure out where the hang up is or the problem.

Well just tried using UGS to act as the gcode sender and same results Z-Axis or the controller is either not allowing anything past 1/8 inch or lol i don’t know. Now I have tried files from Vectric and gcode from easel with identical results. Could something be wonky with the firmware? Is there somewhere I need to set the wasteboard or home height in the machine. HELP!!! driving me crazy

Upon further testing I set the carve depth to 1 inch and what I noticed is it does not seem like the z-axis steps down after it makes first pass on the pocket, it stays at the same height. Only thing I can think of is the firmware is not allowing to read and interpret the g-code for the depth adjustment. How do I re-install the firmware to see if this is the problem.

Sorry its been awhile since I used the CNC so can remember some of these things.

It sounds like your cnc’s calibration settings are set incorrectly, and are actually set for the Newer version of X-carve…

Below are the default grbl Settings for the older version of X-Carve.

The more simple method (as I suggested in the prior comment) is to redo the machine setup in Easel and select the correct year model of X-Carve to have Easel automatically assign these settings. OR use the steps and the table provided here to do it manually>>

Thank you Seth -

After going thru the setup yet one more time, I think the operator pick the direct drive instead of belt w/acme can’t confirm but I think that was the case. But upon examining and comparing the $$Values as you suggested I noticed that values $132 etc had a value of 750 by default but the file reads 790. Should I change the values to 790?

One thing I did notice is the safe height after probe is not sufficient so I do need to modify that.

Let me know if the change of values is necessary.

$130 and $131 can be altered to 790 to squeeze out an extra 40mm of working space depending on exactly where the limit switch is placed… usually changing it to 790 is fine, but you could verify by jogging after changing it and ensuring the cnc faults out at 790 before physically crashing… into the end stop.

Thanks for all the info Seth…

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.