All wired. The machine not respond to commands (SOLVED, solution below)

Hello,

I just completed the wiring of the axis into the control unit.

When I turn on the control unit I see a BLUE light, and 3 GREEN led on. I can move all the axis with some effort (with hand) but when I make the Machine Setup the Axis does not respond.

To be more specific, they looks like to receive the command but seems that they (the motor/axis) are sort of blocked.

The Z-Axis is the one that seems to be more efficient though it not go upside down correctly. At some point (like in the middle of the ACME thread) it also make a “strange” rumor and try go on (back and forth) with a lot of effort.

The other Axis also seems to receive the command, in fact if I press right on the X-Axis I can see it try to move into the correct direction, and that is for the Y-Axis too. But they don’t move correctly, seems sort of ‘seized up’/blocked…

What problem could be? I’m first thinking about the terminal block wiring on each axis but I have checked them 2 or 3 times during the assembling and they looks ok (I will check them again tomorrow), OR/AND the V-Wheels setup.

Have you some idea on that?

Thanks again,
Alex

When the power is off you should be able move the X and Y axis easily. If it hard to move you may have the eccentric nuts too tight.

Can you figure out me “how much” easily"?

The rumor I got from the machine is like the motor are blocked but in fact I am 90% sure the wiring is ok.

Let’s focus on the X axis first. Test each of the eight vwheels to see if you can spin it with your thumb.

If the vwheels all move then the problem is either with a short in the wiring or a problem with the belt.

Whit a short in the wiring do you mean that maybe there’s one or more wiring that are touching each other while they don’t have to? Maybe in the terminal block or somewhere else?

Yes if a single strand of one of the 4 motor wires is touching another of the motor wires you will have serious problems.

Check your vwheels first the look at wiring.

Ok so list of thing to check tomorrow (is 22PM here)

  1. V-Wheels setup
  2. All wiring setups
  3. Belts setup

Of couse I will check the X-Axis V-Wheels first and try to setup it with Easel if is ok. Then go on with the other axis if the problem is that.

Anything else?

That looks like a good plan. Let me know what you find.

If all of that seems ok, check the potentiometers on the stepper drivers to be sure they are set properly.

If any of the above turn faulty, what is the next move? Just to know.

P.s. Maybe it can help but I still have to solder the limit switch (they arrive next week) and set the potentiometer of the stepper. In fact I wanted to make this setup the last if everything was moving correctly, but…

Could be a power problem? Don’t know, like the don’t receive enough power?

Though the Z-Axis seems to move nicely, apart of some point where the motor seems do a lot of effort and get stuck in its position.

The potentiometer is what determines how much power the stepper is getting. If set too low, the stepper will not get enough power and act like it is stuck.

And can I check this even if the first Easel setup went bad? I thought that It can only be setted if all the axis are woring good. I’m wrong?

It is possible it’s a power problem but that is unlikely. If the voltage setting is too low or high you will notice it latter when tuning the machine after you are done with setup and everything is moving correctly. Just check to see if the voltage pots are set mid way between low and high for now.

If I had to rank the probabilities of what is causing your problem:

Vwheels too tight 45%
Electrical short or improper connection 40%
Other mechanical issue (belts or improper assembly) 10%
Power supply 5%

First 2 is what I think too. That is a sort of encouraging if I have to be honest.

I’m not a electronig/wiring type of guy, for me just have the control unit that show the correct led colour is a sort of win LOL

1 Like

Hello @AllenMassey

I tried your advice and I totally loosened the V-Wheels on the X-Axis just as a test. Of course the machine move nice and smooth.

I guess we have found the problem!

THANKS!

Alex

1 Like

Oook now I have another issue.

I just wanted to make a test cut (without the the router bit) but the program can’t find the machine!

Also solved this!

Deleted the Easel Local 0.2.3 and installed Easel 0.2.2. Now work fine!

That is progress! So now the motors will move the spindle around the X and Y axis?

Your next challenge is to find the sweet spot where the eccentric nuts are just tight enough to remove any play in the carriage, but not so tight that they stop the carriage from moving. I found that you want to tighten the eccentric nut until the vwheel become tight enough that it offers resistance when you try to turn it with your thumb.

When you have the X and Y axis dialed in, you can start with the Z axis which offers a few different challenges.

Then we can look at setting the voltage levels to the motors.

Hello!

I have completely loosened all the V-Wheels on every axis (except the Z) and made that test. I also tried to “engrave” something with the spindle off and looks like the machine respond perfectly (even the Z) and complete the stage.

Of course with the V-Wheels ALL loosened I don’t know how much precise the machine is and if it work as it should be, but for now I know that my problem was the V-Wheels so I need to tune them perfectly.

What I have to do with the Z? I pretty much understood how to set the pot, but not the code part.