Any tips to keep my new xcarve from destroying its self

so ive been using my xcarve for about 3 or 4 days now. and its tried to self destruct like 6 times now. particularly the z axis and home position glitches. and it never cuts to the correct depth. i always have to repass with deaper settings.

i cut some stuff with easel and then moved over to vcarve and ugcs.
ugcs scares me because weird stuff happens with it home position and incorrect cut and misalignment happens.
when asking it to drill holes. it plunged through most of my material and then tried to travel full speed to its cut hole with a drill bit. and i yanked the plug.

any help and tips are appreciated

I had some scary moments when I first started using Vcarve and UGS.

Here is what I learned was causing the crashes I had:

  1. I was not using the correct post processor for Vcarve. When I loaded the X-Carve Inches post processor I fixed those problems.

  2. I was not paying proper attention to the X/Y/Z work zero values displayed on UGS. Before you click the send button be sure all three work position values are at 0

  3. I found that the tool change command in the header of the post processor was causing odd behavior sometimes (1 out of 3 times). I finally deleted the tool change command, but before I did I would position my bit at the X/Y/Z zero position and then exit UGS and restart it to force the home X/Y/Z zero to be all zeros then I would reset the work Zero so all six number were zeroed before clicking send. After I removed the tool change command I no longer need to exit and restart UGS.

  4. Be 100% sure where you set the work zero location in Vcarve! It is very easy to mess that up since Vcarve will default the zero position to the last location you set it. If you have Vcarve set to use the center of the work as zero and you set the spindle at the lower left corner, bad things will happen. If you set the zero to the bottom of the work in Vcarve and position the bit at the top of the work even worse things happen.

  5. Check the Z1 Clearance height in Vcarve, If the Z1 value is 3 inches then the spindle will try to go up three inches before it moves in X or Y and that will cause the spindle to crash into the upper limit. You want the Z1 value to be just large enough to raise the bit over any clamps you have on the work.

  6. Plug the spindle and controller into a switched surge protector if you do not have an Emergency Stop switch wired into your system. That is a very inexpensive way to have a single off button to kill all the power if things go bad. But you really should instal an E-Stop.

  7. Be sure your work is really clamped tight beyond what you think you need. Or even better screw the work down to the wasteboard (or install a secondary wasteboard to protect your real waste board from the screw holes). I have had work come loose from clamps that I was positive were tight enough. Do not underestimate the lifting force that a upcut bit can generate on the work.

  8. Use the most recent version of UGS (the 2.0 nightly build version). I was seeing all kinds of odd errors from version 1.7.

When you just jog the Z axis, without sending it any gcode, does it move the correct amount? As in, have you measured it and made sure that when you jog it down 5mm it actually moves 5mm? It might be as simple as tuning the z axis movement settings with something like universal gcode sender.

Have you checked the gcode for g28 lines? Easel wont issue g28 as far as I know, but some other gcode generators will. You can just open the gcode file and remove g28 lines, unless you want to go through the setup process for it.

One thing that has bitten me a couple times is forgetting to reset my home before sending the gcode file. If you’re not using automatic homing of any type, you have to set home once you’ve positioned the head correctly. Otherwise it will first seek it’s original home position and then start from there.

ok. in order

  1. i already selected that. saved me so trouble early on with a tutorial

  2. i need to make a habit of that. because i think thats what screwed me a few times.

  3. how do i do that

  4. loud and clear. i want to standardize bottom corner anyways.

  5. no problems yet. bit i will look at it deffenatly

  6. noted. as well i do use a sheet of plywood as a secondary waste board when i plan to cut though.

  7. i will double check but it should be recent

thanks for the tips.

and NicholasKoza. thank you. i actually should have thought of that. but i will now.

To remove the tool change command from the Vcarve post processor, Open Vcarve and under the File menu click the the “Open Application Data Folder”

Windows will open a file explorer window that looks like this

Open the “My_PostP” directory. (Hopefully you have put your X-Carve Post processor files in that director, if not you should)

In the “My_PostP” directory you will see the X_Carve_inch.pp and X_Carve_mm.pp post processor files

You can edit these files with the windows notepad editor.

So open the one you use in notepad (I use the Inch version)

In the editor look for “Header” section, It will look like the text below. You want to just delete the “T1M6” line. Then save the edited file (with the same name in the same directory). Then that Tool change/selection gcode will no longer be sent to the X-Carve. That Gcode should just be ignored by the grbl processor, but it seems to cause the machine to move to some unspecified location sometimes. I am not really sure why, but after I removed it, UGS worked much better.


  • Block definitions for toolpath output



  • Commands output at the start of the file

begin HEADER

“T1M6” <---------- Delete this line
“G0 [ZH]”
“G0 [XH] [YH] [S] M3”


  • Commands output for rapid moves


“G0 [X] [Y] [Z]”

M3 starts the spindle. I forget what stops the spindle, I think it’s M5. If you’re using a GCode sender that has a serial port window built into it, like Chilipeppr, send M3 before you send the automated GCode. I once hit “send” in Chilipeppr and the spindle didn’t turn on. So down went my precious, new 0.006" diameter tip engraving bit into pcb copper and snapped upon contact. Happened faster than I could react. Now I turn the spindle on manually before sending code just to be sure.

Here is a G and M code chart I find it really handy. The first 0 in G00 -G09 is not needed and the same goes for the M codes M00 - M09.

1 Like

I also added “G90” to my header
This makes sure that you are carving in “absolute mode” as opposed to “relative mode”

I noticed that UGS used relative mode commands when you jog the machine manually.
So by adding the G90 to you header you are insuring that it switches back when you run your file.
I am not sure if it is necessary but I figure it is a good idea to have it just in case.

Good idea, it can’t hurt.

im diffidently going to try these things out.

i did have decent success for now. marking my start position with the spindle(as long i its not part of the final cut), and rebooting ugcs to reset all location values. but its been cutting alot better lately with better startup practices.

thanks guys

ok. so after a full week of no accidents. id say im starting to get the hang of it. thanks again for all your help guys.

Glad you have it working correctly! Post a picture when you make the first project that you are happy with.

yeh i will. ive already posted my build log. but my first non test cuts are in there developing state. got a drone frame that i cut out of wood and im super excited to see that i got scale correct on my first try. beings i couldnt find a scale system in vcarve for bitmaps. i sorta did something unorthodox and it worked great.

now i just need to cut some more clamps out because warping plywood is really a hassel when its 2x2 feet and 4.5mm thick.
and when i get the new remodeled frame ill be ready for g10 after i retest scaling.

1 Like

A simple resolution to the emergency stop is to plug everything into a cheap surge protector with an on/off switch. When an emergency arises, just turn off the surge protector and the router, control box, everything but the computer which goes to battery mode, turns off immediately.