Anyone elses machine have trouble jogging 0.01"?

Tried to jog the machine 0.01" on the X axis and it just sits there and makes a clunk noise.

I tried tightening and loosening the belt and i adjust the current pots higher and lower with no change. V wheels are tight but i dont think excessively so.

Not sure whats going on

Just double checked, its actually having issues with anything less than 0.04"

Only on the x axis. Y axis has no problem down to 0.001"

Im kind of worried about this now. If the computer is telling it to move in dmall increments and its not physically moving thats a problem

Want to add i doubled check the pulley to see if it was slipping but its not and the shaft is not turning

You could try swapping the x-axis motor for one of the y-axis motors and see if the problem remains on the x-axis. If the problem remains on the x-axis, then look more closely at the x-axis belting, wheels, pot, wiring. If the problem moves to the y-axis, then you likely have a motor problem.

Yeah thats not a bad idea. I will give that a try

I sat down with a calculator and ran some numbers. IF your steppers are 1.8 degrees per full step and 200 steps per rev. If you are set to 8 micro steps that is 1600 micro steps per rev. If you have a 20 tooth pulley with 2mm pitch that is 40 mm per rev or 1.574" per rev. If you want to move .001" that is 1.0165 micro steps.

That is asking a lot from your Chinese stepper driver. It may not be up to the task.

This got me to thinking of another mod that I may do to my machine. Build a reduction gear box so I can get my steps up to a higher number for very small moves. It would be a belt reduction. I can get the belts and pulleyes I need from SPI.


Dave the Y and Z axis have no issue moving down to 0.001" however the X axis will only do 0.04" anything smaller it trys to turn but just clunks

And that could be the fault of the X stepper driver. Have you swapped X and Y drivers to see if the problem stays with the the stepper motor or stays with the stepper driver.


Thats what matt suggested above, going to give that a try tonight

well now the Y axis wont jog small distances. screw it i give up. having way too many issues with this thing. had it for almost a month and a half and havent made a single clean cut

Sorry to hear you are having so meany problems with your machine.

The published resolution is .0029" to .005" with the standard electronics. I’m starting to think that without some heavy mods and changes from the standard electronics package you will never see a resolution of .001"

What would you like to make that requires .001 resolution.


again its less then 0.04" that its having an issue with

the z axis works to 0.001" and at the time y did, didnt see why the x and now the y wouldnt. maybe i just asked for to much.

OK I put an extra 0 in your .04" number. 40 thou is a problem. What is Inventables saying about this issue.