Inventables Community Forum

Anyone recently had any luck with the Linux Driver for Easel?

I’m having the same problems as the original post. I bought a new Chromebook, installed Ubuntu 18.04.4 and downloaded the Easel Driver (0.3.18). I can’t get the carve button to turn green, it stays blue and doesn’t recognize that the driver has already been installed (or that the XController is plugged in).

I ran sudo lsusb -t and I see a difference when the XController is plugged in:
|__Port 2: Dec 23, If 0, Class=Vendor Specific Class, Driver=ftdi_sio, 12M

I ran the sudo adduser “your username” dialout, but didn’t see any difference.

I used Gdebi to install the driver and it appears to be installed, because when I open Package Installer it says “Status: Same version is already installed”.

I’m using Firefox for my browser as I saw that some people were experiencing issues when using Chrome.

I’ve downloaded Universal GCode Sender but I don’t know how to use it. I’m very new to Linux.

Is there any way I can get this machine to run my Xcarve? I’m not sure that I can return the computer now that I’ve installed Linux, and if I can’t get it to control the Xcarve it’s not much good to me!

Thanks so much for any help you might be able to provide.

Hi there. I got big big problem with driver. i make many things and still not working.

uname -a: Linux garaz 5.3.0-28-generic #30~18.04.1-Ubuntu SMP Fri Jan 17 06:14:09 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

After run easel driver i got this:

2020-03-29T11:19:57.460Z iris.js [id=0] Starting Easel Driver 0.3.18
2020-03-29T11:19:57.467Z Machine [id=3] Resetting
2020-03-29T11:19:57.491Z iris.js [id=0] Listening on port 1438 for secure connections from easel.inventables.com:80 easel.inventables.com:443 easelstaging.inventables.com:80 easelstaging.inventables.com:443 easel.invinternal.com:443 easel-secure.inventables.com:443 easel-insecure.inventables.com:80
2020-03-29T11:19:57.495Z iris.js [id=0] Listening on port 1338 for connections from easel.inventables.com:80 easel.inventables.com:443 easelstaging.inventables.com:80 easelstaging.inventables.com:443 easel.invinternal.com:443 easel-secure.inventables.com:443 easel-insecure.inventables.com:80
2020-03-29T11:19:57.773Z Websocket Controller [id=4] Client connected via polling
2020-03-29T11:19:58.072Z Websocket Controller [id=4] Client transport changed to websocket

i Make change port , install , reinstall, chown /dev/ttyUSB0, adding to group dialout , edit serial_port_controler.js and nothing. Still:

Connecting to X-Carve…

Plug in your USB cable and turn on the machine.

Pls Help

ps. In Universal G-code Sender works good

Hi @SeabrightWoodworking, can you try the latest version of this easel-driver? The update today solve @Hugo’s issue so may solve yours as well. No need to change any files.

cc @DavidKidd, might solve for you as well