ArtCam Software

Does anyone know if ArtCam software will work on this machine? They don’t have an Xcarve post processor but can you use a standard Gcode output to work??

I think there are certain Gcode items in an ArtCam produced Gcode file that will not work with GRBL. That being said, you could always run the machine with a different controller.

Noted as working on the ShapeOko wiki, just use the Mach 3 PP.

I have ArtCam express and it works fine on X-carve, post processor they suggested is the Mach 3 and it works just fine with X-carve and standard spindle. I used Chilipeppr to run the gCode files.

Finished my 1st releif carving and was really impressed.


Can you tell me which Mach 3 post processor you are using with Artcam to create your gcode files for the xcarve? I have the following Mach 3 post processors listed in Artcam:



Thanks in advance,


Hi Charley,

When you save the toolpath in ArtCam it takes you to the list of post processors, go down the list and choose the post processor from the list called “Mach3 EZ router Boss 5x8 arcs ATC(inch)”.
Subsequent saves will use this automatically. I have been using this with success, and note that I also use the X-carve quiet spindle (supplied as standard when I bought my machine).


Thanks for the quick reply Bob. Unfortunately I don’t have that post processor listed in my version of ArtCam. I suppose I will try both of the Inch versions I have available and see if either of those will work doing an Air Cut on a simple design. I compared the output of the two I have available to the same design that I get when exporting from Aspire using the xcarve post processor file available on this web site. They aren’t exactly the same but similar. Wish me luck.



If you tried this can you let us know which PP worked for you?

Firstly I would like to thank the people who were discussing here!

I used ArtCAM 2017 and face difficulties in sending the codes to Shapeoko 2 CNC machine (the version before X-carve). Finally the post processor that worked is “Mach3_4(MM)(*.TAP)” ! I dont know whether it is the correct PP to be used but it worked.

Now I can mill 3d surfaces!

1 Like