Aspire/Easel tool change?

Hello Everyone,

I have been chasing my tail on both this forum and the Vectric forum looking for a solution that I can understand… The solution is probably the easy part. It is the connection between the keyboard and the chair that is giving me fits.

What I am trying to do is to use the “clearancing tool” function to allow me to spec a large tool for clearanceing and a fine tool for the detail.

I need the machine to zero, run the clearance pass, zero, allow tool change and then run the detail tool.

I am creating in Aspire and generating the G-code then importing the G-code into Easel.

I have read several discussions regarding this task but found no solution.

Any assistance would be appreciated.



I do this all the time. I set a vector boundary around my work piece, that is offset to the outside by a distance that I feel. Omfortable with, usually .25 to .5 inches. I set the carve to a pocket carve using a .75 inch bit, with the vector boundary as the edge of the cut. I set depth of cut to .002 inches. My speed is set to no less than 100 ipm. This ensures not only a clear surface, but one that is perpendicular to the Z axis as well. I also use Aspire.

Thanks fro the replies,

When creating toolpaths there is a check box for using a larger clearancing tool to speed up the carve.

I need the machine to home and pause for the tool change to go from the clearancing tool to the fine finishing tool.


I tried simply checking the box to use the clearancing tool, picked the appropriate tool and attempted to save the toolpath (G-code).

I received the following message:

“Error: The visible toolpaths use different tools and the selected post processor does not support tool changing.”

Thanks Robert,

I will be back in the shop in a couple of days and give that a try.

Thanks again Robert.

That worked. I went a bit more “granular” and started naming the tool paths with a reference to the bit used. It only took one occurrence of using the wrong bits to figure that one out…