Auto Z zero Fail

I installed a z zero toutch plate on my machine. the toutch plate has a wire going to pin a5 on the arduino board and there is a clamp going to my bit with a wire going to the negative terminal of my power supply where the spindle gets it power

I am using the grbl shield on an Arduino
The commands I am using are from charlie thomas
The machine moves very slowly for about 1/16 inch then stops and the UGS ver 1.0.8 says probe fail and alarm goes on
It does this for the z x and y
<img src="//discuss-assets.s3.amazonaws.com/original/2X/e/eda8e9e458b68329e3cc434949fbb9ae65bd5bc3.png" width=“566” height=“475”


if you want the excell work sheet i am using ill send it to you jusr send me your email
here is a video of what i did. this is not me i just got the idea from this video

youtube Auto Zero CNC X Y Z Axis

Are you using UGS to send the command? What command are you sending to use the plate?

yes i am using USG to send the command lets say my bit is 1/8 so .125 and my plats is 1/2 so .5
the first line of code i would run is for the x then y then z and it will look like this

x G38.2 X-.5 F1;G92 X0.0625
y G38.2 Y-.5 F1;G92 Y0.0625
z G38.2 Z-.5 F1;G92 Z0.5;G0 Z0.25

it moves 1/16 inch in said direction then UGS says probe fail and alarm on does not mater order xyz
yxz zxy ect same every time

Make sure under machine control tab you are set for inches…mine did the same thing.

And I don’t use the G0 Z0.25 command after zeroing the Z axis, I just jog the bit up a bit and start my project…

(I think someone else pointed out that you’re probably in metric, not fractional, so you’re moving 1mm not 1/16th of an inch.)

I use this UCS macro to adjust my settings:

g91; G20 ; G38.2 Z-1 F3; g10 p1 l20 z1; g54; g1 z.1; g21

Translated:
g91 - switch to relative mode
g21 - fractional instead of metric (I use a 1-2-3 block that’s 1" high as a touchplate)
G38.2 Z-1 F3 probe down one inch (that’s the -1) at a feed rate of 3" per minute
g10 p1 l20 z1 - set the Z work coordinate for the G54 workspace to one inch below its current position (since I know my touchplate is 1" thick). I set my X and Y somewhere else, not using a probe. [You want to look at http://www.shapeoko.com/wiki/index.php/G-Code for the g10 documentation. Be prepared to cry/laugh; gcode pays no attention to any sort of sensible software design.]
g54 use the G54 workspace
g1 z.1 move up one tenth of an inch off the touchplate
g21 switch back to real measurements (aka metric).

I think the a problem you have is that you’re adjusting your machine coordinates. Those shouldn’t change; you should adjust a workspace instead.

If you’re using UGS, “jog the bit up” is a button or keystroke that sends g91 g0 [something] to the Arduino. It’s doing the same thing.

You are correct, it is just not a part of my macro.

Ok got it fixed by finding a faulty ground in the clip end that goes to my bit. Auto z zero now works. Do I need a 4th line of code to bring it to true z zero or will it just know where it is because of the zeroing process