Blackbox Controller Z-Axis only moving 25%

So my XCarve Controller burnt out and it was recommended that I upgrade to the OpenBuilds Black box. So far so good except my Z axis is only moving 25% of what I ask for. Meaning while testing the step movements, Y & X both moved the 1 inch i asked it too confirming everything is set right. But the Z axis moves .25 of an inch. I have the voltage set all the way up but no change. Any ideas?

Thanks!

Suspect you did new machine set up for the current new Z axis.
You just need to revise your steps/mm for the Z axis.

The OpenBuilds Black Box product listing states it includes the ability to set microstepping, BUT i don’t see how, maybe it’s within software or maybe it’s a jumper setting like most other controllers, BUT I don’t see these jumpers on the images or videos I’ve found of it.

These micro stepping settings are in increments of 1/2’s So 1, 1/2, 1/4, 1/8, 1/16, and 1/32 (the Openbuilds listing says up to 1/32 so I’ll stop there)

Specifically for the Z axis:
The Xcontroller board is set to 1/2 microstepping by default
The OpenBuilds Black box is set to 1/8 microstepping by default

This explains a 4 to 1 variance on movement.

You’ll need to figure out how to adjust the microstepping settings on the Black box and make this change.

My supporting evidence:

Now, Mark could also be correct IF the Steps/mm are off that will cause a similar issue, BUT the old vs new Z axis setting are a 1:3.786 variance not a 1:4 like you’re reporting BUT very close, so close that it could be either of these causing the issue. . .

For this Reason you may also want to verify you have the correct setting for your Z axis AND the correct micro stepping settings.

The old version Z axis grbl setting:
$102 = 188.947

The new version (with linear rails an a top mounted Z stepper) settings:
$102=49.909

Some info at the top about how to get to these settings: