Bug? cutting depth preventing change to Z

I’m trying to change my material Z but getting the following message.

“Some objects in your design are set to carve deeper than 0.2 in. Make the depths shallower first and then adjust the thickness.”

I wish it was the obvious, but I’ve gone through every object in my design and the deepest setting is 0.2 in. I’m going to set depths to 0.199 in, but wanted to pass on the potential error.

I’m not sure if there is a bug in Easel or an object is hidden some how.

I’m working with ‘Spring Joint Box Electronics Enclosure’ from the Inventables’ project library. And unfortunately 1/4 in plywood from Home Depot is 0.2 in these days, not real close to 0.25 in…

Oh I’ve ran into this so many times! I would suggest using CTRL + A and setting depth to 0. Change material depth then change cut depth. It should work.