Can I use Easel with my Vevor 8080 CNC Machine?

Please help! Can Easel be used with my Vevor 8080 CNC machine? We are new to all of this, and my husband bought this machine online. I have downloaded the Easel driver; I have selected OTHER and attached a screenshot of the default Machine Settings; I did not do anything under GENERAL SETTINGS and I have attached a screenshot of what it says when I click on it.
However when I click the blue toggle box in the upper right corner (I think that’s the button I push to start carving on my machine, right?), I get a “Machine must be turned on and plugged in” message. When I click TROUBLESHOOT I get a message that says it can’t find my machine automatically (see screenshot) and I have checked the box to “Enter COM port manually” and selected COM Port 3 (as shown in screenshot of the Device Manager).
Note: We have new HP laptop using Windows 11, Chrome browser.


Screenshot 2022-04-10 194018 Easel machine General Settings

Did you enter a different com port manually. You might try that say com port 4 or 5.

1 Like

What Wayne is suggesting (and I agree with it) is In device manager, right click that com3, go to properties and force change it to 4 or higher unused number… You may also want to verify the baud rate setting (IMO 115,200 works best)

I suggest this change because some computers reserve 1-3 for peripherals like mouse, keyboard, printer and cncs don’t always work properly using Com1-3.
Then I suggest rebooting the PC with the usb plugged in and windows will automatically update the driver if needed.

Then retry easel machine setup.

.
.
This next part is unrelated to your current issue, but this is a best practice to make this settings change as well to prevent usb disconnect during longer carves…: Set USB selective Suspend to Disabled mode: How to Disable USB Selective Suspend

1 Like

@SethCNC Thank you for the clarification…however, I am not sure how to “force change it to 4 or 5”. This is what I get when I click on properties:
Screenshot 2022-04-11 092120 USB Serial Port Properties
UPDATE: I answered my secondary question above by clicking on PORT SETTINGS, then ADVANCED and and saw a dropdown where I could change COM Port Number.
However, I tried both 4 and 5, rebooted each time, and when I opened my project in Easel and hit the carve button, I got the same message.

@SethCNC where do I verify the baud rate setting?
I apologize for my limited knowledge, and thank you for your clarifications.

Not sure on that but it could be in your machine setup.

Do you have any other software open that the machine might be connected to? (Candle, UGS, etc.)
Try restarting the computer and powering off the machine. Open ONLY Easel, power machine back on, and then try.

1 Like

I have rebooted multiple times and only have Easel opened online, and no other devices plugged in to USB ports.

What operating system?
What Browser?
Can you connect to any other senders?

We are using Windows 11, Chrome browser. I finally found Candle software that came with the machine, but I have no idea what to do with it. :pensive: Is it possible that I will need to use Easel to design my project, then export gcode file to open in Candle?

Well, some users do find themselves needing to do that. But the root cause of the need to do that has to do with computer settings that are not allowing Easel to gain control of the USB…

So what I would do is install Candle onto the computer, and connect through candle, verify that candle gets a proper connection to the cnc, and then try Easel again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.