Can not get Easel to connect to Genmitsui 4040 Pro

I am about ready to give up! I bought a new Genmitsui 4040 Pro, have Win 11 on my laptop, signed up for Easel Pro demo. After two days, I still cannot get this to work.
I tried CH430 driver (thought it worked but then quit), tried CH431 and same result, tried FTDI (Nope!), downloaded the new Easel 0.4.0 driver(No go!)
Can someone help me figure this all out?
Near the end of my rope!
Jim S

I use Candle that was included on the USB drive of Genmitsui 4040 Pro.
You have the option to from Easel menu under Project download g-code.
then you are able to bring the g-code file into Candle.
I like Candle because it’s simple to use.

Good luck.


I had that exact same issue’s!!! DONT GIVEUP it’s a solid machine and it works as a beast (though you need to tinker with it a bit)…

This is what i did,

Go to the “Machine” option in the menu bar and follow the steps to add a new machine (use the manual to add additional info if asked)… than check in Windows Device (in settings) at you’re USB ports if the port is not shared with another device… if so remove the device and let Windows sort it out and add them again.

and go in the power savings settings of Windows and make sure everything there is off… you’re Laptop will be powering down some stuff to save power after about 15 min of none use regardless of the power supply is connected on it, but the CNC machine needs constant connection… to USB and Network…

Windows does not see you’re CNC machine as a active device so it will power down ports, display and connections (Bluetooth and Network)

So daylight saving, power saving off… (well for me that did the trick)…

Let me know if that helps…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.