Cannot clear gshield after and alarm

Hoping this is the correct place to post this. Thank you in advance for your patience and wisdom.

I am very new CNC. Picked up an 1000mm XC this summer. Just finished assembly. Some minor mistakes running wires through drag chain, but easily fixed. Great instructions.

During the Calibrate step, I began to set the stepper motor [current] on my NEMA 23s. Looked a little too complex, but I wanted to follow the directions. Details are a little fuzzy, but I installed drivers for Easel, ran the test file apparently successfully without a bit. Then I used it to send recommended gcode commands to adjust current. I read I could use the Machine-> Advanced->Machine Inspector to send the code. Somewhere, it hit the ends of the maker slides and I hit the reset button on the g shield.

Alarms have gone off and reset commands ($X or $H etc) in Machine-> Advanced->Machine do not appear to work. Keeps giving the same location in an apparent endless loop of trying to move or find itself. Eventually, had to leave so I powered down and disconnected from computer.

I can provide images and specs as needed. I will try again when I return to work tomorrow.

Please advise or direct to the appropriate thread to reset and/or troubleshoot. I am sure these are rookie mistakes, but I hope you all can save a massive error on my part. Thank you all.

Thanks Phil. I sent a G0 y1000 command as instructed under the heading Setting Motor Current on this page: https://github.com/synthetos/grblShield/wiki/Using-grblShield#setting-motor-current

Not sure why I chose y axis. I have in my troubleshooting notes to try that. It has just moved to the top of the list. I appreciate the quick reply.

Y750? If it’s 1000mm and you have 750mm travel

I do not know why but sometimes the gbrl or arduino gets messed up.
I had to go through easel and do a machine setup. This cleared the issue I had.
Could help or may not.
Just throwing it out there cause if you did not do this yet it could help.

Just to come full circle and say thank you. After returning to work I started anew. Restarted browser and Easel and plugged in laptop. All was well. Tried to rehome, but it appeared I may have crushed my y limit switch. A small prices to pay considering my novice status.

What I learned: 1. Units matter. 2. Learn where the brake is before you use the gas. 3. This is a great place with great people offering help.

Thanks again.

1 Like