Cannot connect to xcarve from Mac

Kevin,

OSX version, browser and browser version?

If you cannot even run Easel to produce gcode then your Mac has serious problems.

Cheers

Ian

@IanWatkins I can’t say for sure in @KevinKarney 's case, but a lot of us were having trouble getting Macs to connect to Easel, so as to control the Machine. I am able to use Easel to generate g-code, but then I have to use UGS to run the code on my machine.

I use an old Mac mini to drive my X-Carve with no problems whatsoever. I use UGS the majority of the time, however I have used Easel on multiple occasions without any problems.

Whilst I can understand your frustration, I’d suggest that the issue isn’t an Inventables problem. Almost certainly there is a problem with your setup, your software or some kind of configuration issue.

More than happy to assist if I can help.

I know it’s obvious, but have you tried disconnecting everything from your Mac (unplugging everything but the xcarve) shutting down all software, rebooting and then begin with easel from scratch?

Also, make sure you boot up the Mac BEFORE plugging the XCarve into the machine. If I leave my machine plugged in when I reboot, it won’t find it for some reason…

On top of @DavidWestley’s suggestions, have you installed Easel Local?
this has the be installed on your machine before Easel will work, so if you haven’t or even if you have, you may want to go and install it.

https://inventables.desk.com/customer/en/portal/articles/2120936-easel-local-isn-t-installed?b_id=9562

If you get an “unidentified developer” error popping up, just right click (two finger click on the trackpad) on the Easel Local and choose “Open” from the menu that pops up. It will give you a different warning, with the option to open anyway. Once you do this for one app, that same app will open with a double click from then on.

I have only really seen 3 people with this problem on the Mac so I’m not sure that qualifies as “a lot of us”, but I can understand the frustration. Especially when the majority of the Mac users with X-Carves just plugged it in and it just worked right off the bat.

@paulkaplan is there a direct link to get Easel Local if you have already installed it and need to re-install it?

I did install easel local. I think I even removed it and reinstalled it. In any case, Chrome reported that Easel local was installed. Can you confirm how to remove it an reinstall? I’ll try that again just to be sure. Also, I didn’t mean to suggest that the problem is widespread. I was trying to distinguish between what I’ve seen going on, and a much more fundamental problem as suggested by @IanWatkins.

Waiting to see if there is a direct download to get it again, because I just checked the link on the dev help and it is broken.

Hopefully you’ll be able to download it and reinstall it. Then I’d do a restart just in case.

… but if you want to manually remove it and try and have Easel reinstall it, then here are some steps that will remove it. Attempt at your own risk.

  • in the Terminal.app run this command: (it will ask for your password)

sudo launchctl unload -w /Library/LaunchDaemons/com.Iris.Iris.plist

  • locate /Library/LaunchDaemons/com.Iris.Iris.plist and delete it
  • locate /Library/Easel and delete the folder
  • for good measure restart your Mac without your X-Carve plugged in to the USB
  • go to http://easel.inventables.com/setup and try installing Easel local again

Hi Ian
I am using OS X 10.10.5, Safari 8.0.8. And I have tried latest versions of Chrome & Firefox. I am an experienced Mac user (I bought my first 128k Mac in 1984 - I wish I had kept it!). I have tried everything (restarting with no extensions, etc). The issue is that UGS connects very time and the X-Carve itself works perfectly.

Best wishes
Kevin

1 Like

Hi @KevinKarney,

Did you see my post about trying to reinstall Easel Local?

Thanks sketch42
Yes and I have tried the full de-install and reinstall of Easel Local. No luck. If GCS finds the right port, why can Easel not do so too???

Bizarre Kevin.

I assume you can run Easel ok just cannot use the Carve menu? I.e. Can design just cannot control the machine.

If you have tried reinstalling EaselLocal like Jeremy suggests, and you are super sure UGS or anything else isn’t grabbing the port, then I’m afraid I am at a loss.

The only time I’ve ever had any USB problems on a Mac (I’m a big user too) is a couple of hardware synthesisers really didn’t like being on USB3 sockets but fine on USB2.

I think my final suggestion would be to contact help@inventables.com and ask.

Sorry, don’t know what else to suggest. :frowning:

Cheers

Ian

That’s a good question. @KevinKarney are you able to use Easel to create a design and under Machine > Advanced export the gcode?

I’m guessing you probably can, but it is a piece of the puzzle.

I’ll keep looking for / thinking about a solution, but if you decide to contact Inventables support again then I would try talking to them via their support number.

I took one final step to try to resolve this long-standing Easel bug. I moved my big heavy weight iMac from my study to my workshop. Reinstalled Easel Local (doing it according to sketch42’s full procedure.) Restarted the Mac, tried with Chrome, Safari, & Firefox. Still no joy. I can use Easel to generate Gcode so that side is working. UGS continues to be the only way I can use my X-Carve, which otherwise behaves flawlessly.

All my software is up-to-date. I have no firewalls

I understand that Easel is not yet working properly with Apple’s soon-to-be-released El Capitan OSX (which I have not installed) - so i hope that Inventables will have a good look at Easel’ software.

@KevinKarney. Something just occurred to me. Did you get the electronics kit for Inventables with the arduino included or did you provide your own arduino? I provided my own and ordered the Grbl shield separately to save a little money since I already had some arduinos / clones laying around. Maybe there is something wrong with my arduino. I’ve got several more of different vintages, so I think I’ll see if I can get another one to connect.

The Arduino supplied by Inventables was a dud. They promised to send me another, But bearing in mind the time & customs duties (USA - UK), I just purchased one and had it next day for a few £s. It was (at least to the eye) identical to the dud one. It worked perfectly.

I have finally e-mailed help@inventables.com. I will post the e-mail here in the hope of keeping this thread alive

I sent the following to help@inventables, Paul & Zack Kaplan in the hope of getting some resolution…

Apple Macs not connecting to X-Carve via Easel, but working perfectly via UGS

There has been a history going back a number of months of Apple Mac owners being unable to connect to their X-Carve directly via Easel. You can see details on the X-Carve Forum. Many kind users have proposed remedies, which - for me - have not worked.

I trust that the Inventables Easel developers are aware of this problem.

My situation is this - and it is similar to others faced with this issue…

I have up-to-date Macs - both IMac and MacBook. I am an experienced Apple user.
I have the latest version of OS X Yosemite, and the latest versions of Safari, Chrome and Firefox.
I allow cookies from sites I visit.
I have no unusual extensions, no Firewall and no other applications using the USB ports.
I can create Gcode with Easel - save it to file - and route it to the X-Carve via Universal Gcode Sender.
The X-Carve works PERFECTLY, CONSISTENTLY and ACCURATELY. Therefore, I conclude that there is NO problem with GRBL, Arduino or the X-Carve itself. The X-Carve is a lovely bit of engineering.

All the usual remedies have been endlessly tried…
GRBL software re-installed via the Paul Kaplan’s Hex loader
GRBL software re-installed via the Arduino app
Easel Local completely de-installed (using Terminal app) and reinstalled.
Restarting the Mac, changing to a different Mac, changing the USB cable, changing browsers, etc.

I conclude that the problem relates to Easel Local - it cannot find a suitable USB port or set a suitable baud rate to communicate with the Arduino or something else.
I understand that the issue also relates to users who are using beta versions of the El Capitan version of OS X

I await your advice and or resolution
Best regards from a frustrated
Kevin

Best regards
Kevin Karney MA, JP
Freedom Cottage, Llandogo, Monmouth NP25 4TP, Wales, UK
51° 44’ N 2° 41’ W Zone 0

  • 44 1594 530 595

I am having the same problem, almost exactly as described, and have tried all the same things. I am planning to have one of the nice people from Inventables remote log in to my machine this afternoon and see if we can’t figure something out. I will report back if anything is resolved.

That’s great @BradleyKFritz. They offered to do that for me as well, but I haven’t had time. I hope you are successful in getting to the bottom of the problem.