Cannot Connect

I was having issues connecting to my XCarve Pro after a recent update to google chrome. Couldn’t for the life of me get it to work. So I tried to update the drivers. It completely bricked my laptop. I upgraded the drivers from the inventibles website and now my PC won’t turn on. Completely blue screened it. I cannot even get BIOs to reinstall Windows… so, there goes a $4000 laptop.
So, I bought a new Surface Pro and now the XCarve pro won’t connect to that at all… I tried all the browsers, updating all the drivers. But it just doesn’t show up.
Please help! My whole setup and shop are at a standstill

Can you go back to an earlier restore point? I can’t imagine the driver updates would screw up the computer, but I’m not that computer savvy.

How to Properly Reboot (Restart) a Windows Computer (

Force a shutdown and restart your Surface - Microsoft Support

1 Like

Yeah, it did something to the hardware I guess? I used to be an IT guy, so I have some understanding. I tried restore points, I tried reverting via a USB, I tried an external CD Rom for goodness sakes, lol.

Note, new PCs are not coming with regular USB anymore, so I only have USB C. I have had to get a USBc to USBc for the connection to the PC. Could this be the issue? Also, Windows 11 doesn’t have Ports in the Device Manager, so the instructions on their website are old and out of date.

Note, I’m also now trying on a new Dell laptop using USB C as well. Also not working here.

You might try downloading the Universal Gcode sender and see if you can connect to that.

My windows 11 with all current updates has ports listed in device manager.