Can't get the easel driver

Finished building my XC 1000. Easel says I need to download the easel driver. I did that several times. It clearly downloads but nothing happens. I’ve gone to the folder where it’s stored. It’s there but when I open it nothing happens at all. The computer thinks for about 30 seconds then stops, and that’s it. Any ideas?

My device manager says device 5880 has no driver. Is that the XC?

You need to unzip the files and double click on the executable file to run the installation. Have you done that?

Many times. But I have not seen an executable file to run. I see the zipped file. Double clicking that unpack the easel 3.3 file (not looking at it this moment, but I think that’s right) however it not an exe file and does nothing when either double clicked, or if open is selected

At this point in my carving career, I don’t know of nor am I able to use any other choices. So that may he all it is, but it seems pretty valuable/important to me. I’m trying 2.2 now

2.2 seemed to install. I tried many other versions between 3.3 and 2.2. None except 2.2 did anything at all. 2.2 took me through the initial setup, but would not allow me to carve. It said it’s out of date and no longer supported. It asked me to updated to a newer version, which I tried, but to no avail.

I will call Inventables tomorrow and see what they say. I did at least get to see it move during the machine set up, and I do know at least that things seem to be wired correctly. That’s something at least

I started having problems with mine yesterday for the first time ever, right after a Windows10 automatic update. My computer stopped talking to the x-controller and if I figure it out, I will post the fix. It is frustrating.

Something about the Windows 10 creator update seems to be causing issues with Easel.

In my case at least, I’m using a laptop with Windows Vista Business.

I’m a machinist (manual) /Gunsmith, no where near a computer guru. Is there a way to get rid of the issue or am I going to have to restore back to a point before the update? Maybe I should just get my wifes junk Dell laptop to run this thing and let my grandson find out that the computer grandpa uses with the cnc is a really high powered gaming computer…

Not sure what the root cause is. @Zach_Kaplan @JeffTalbot Have you guys seen this? I know Microsoft doesn’t make rolling back a version in Windows 10 easy. It’s difficult for me to do it and thats what I do for a living.

Yes, the creators update is currently incompatible with the Easel driver. We have a new version of the driver in testing that should resolve this issue. We will follow up as soon as it’s available.

Thank you very much Sir. That’s srvice.

My problem has been resolved. I was on the phone early this morning with Mo (Inventables, she’s fantastic!) who worked with me for an hour. Turns out there was no firmware on the X Controler. She fixed it lickity split. Also turns out I needed a new computer. I fixed that lickity split as well.

Plugged in, fired up, cuttin’ like a champ. A few adjustments to clean up the cut. Done and dusted.

1 Like

Hi @WardWilliams, @KentBelew, and anyone else having Easel repeatedly tell you you need to install the driver after installing the Windows 10 Creators Update—

We’ve released a new version that fixes the installation problems on this version of Windows. Please go to http://easel.inventables.com/downloads and download version 0.3.5 (or newer, for anyone from the future).

Sorry for the trouble!

2 Likes