Carve going off path 3 of every 4 jobs

Hello. I just started testing Easel Pro with my brand new ProverXL 4030. Simple stuff so far just to test. And 3 of every 4 carvings at some point go totally off path or just stop before finish. And I see some errors on the offline controller screen.

Any ideas of what to look for? Or what can I do to see why this is happening?

Thanks a lot.


hmm, is the usb plugged into the controller as well? This is a fairly common issue for new users of the offline controller and can result in the USB cable working like an antenna kinda and corrupting the commands that are going to the CNC from the offline controller.

I suggest running the machine directly via the USB and a dedicated Gcode Sender software that way you will receive the proper Alarm numbers to explain the fault when it occurs.
(also you’d want to disconnect the offline controller cable when doing this to prevent the comms noise as well)

It is controlled by the PC. I’m only seeing the errors on the offline controller screen. But it’s Easel Pro who is controlling the machine via the USB cable.

1 Like

Will try the software that comes with the machine. Just wanted to avoid the extra step and control directly with Easel.

Thanks.

1 Like

Ohh, that right there is likely the issue, you cannot have the offline controller plugged in while using USB to control the cnc. you’d want to unplug the offline controller (the whole cable) and run the machine via USB and the erroneous toolpath should resolve itself as well as the fault showing.

IF you do have faults you can see them in Easel by going to the Machine Inspector page (press crtl+shift+D to open this page) and at the top “idle” will say “Alarm” and in the console area an alarm number will show that will correlate to a list of Alarm codes…

Well. It seems that was the cause. I would never ever think of that as the problem. But out of curiosity want to access that page you say. But when I press CTRL+D that’s not what I get. I get an edit bookmark window. If I go to the machine window. I only see this.

1 Like

Oops i didnt type it correctly, its ctrl+shift+D

Or Machine>General Settings>Machine Inspector

Thanks. This solved the problem. :pray::pray::pray:

1 Like