Carve won't start job

Hello all. I’ve got a 2-week old Carve, and it’s been working great so far. However, now I can’t get a job to start. I can home the machine, jog around to a starting point, zero the Z-axis using the probe and get to the point where I click to start carving. The spindle moves to the starting point and lowers the Z-axis to carving depth, but then it just stops there. I get no errors, but the job progression doesn’t move. When I cancel the job the spindle raises to the safe height and returns to work zero. I eventually have to reboot the controller to be able to jog the machine again.

I’ve tried all of the following:

  • Deleted the XCarve machine, and re-added with no issues
  • Downgraded my post-processor to the prior version, same issues
  • Re-installed the 0.4.0 post-processor drivers, same issues

It seems like I should be able to use the Machine Inspector to tell more, but I’m too new to the game to do so.

Any help is appreciated. I’m also waiting on a call-back from Inventables support. If we get it resolved I’ll make sure to update this post.

1 Like

Is this a 3D job? Does the issue exist on other jobs 2D/3D?

I’d use task manager (PC) or activity monitor (Mac) to take a look at what’s happening to the RAM on your machine when you’ve pressed carve as this sound to me like a tool path generating issue, especially if the generation is using more RAM than available.

1 Like

When you go into machine inspector immediately upon the carve stopping, what is the status showing? (Idle, Run, Alarm?)
IF Alarm shows, please check the console area for the last handful of lines of code for a line with “alarm” and a code number… there might also be a line with “Error 9” but that always shows after an alarm and is less important than the alarm number. sooo please grab that number IF it shows the status as alarm…thanks!

@JamesWNZ - thanks for the reply. I’m running on a MacBook Pro with 32 GB of memory. There’s over 20 GB of memory available at the time of the run and it doesn’t really change when I execute. It’s a prety simple job I’m trying to run.

@SethCNC - also, thanks. The status is Idle. would the output from the console help in this case?

1 Like

The idle state tells me that the usb connection dropped out… .

Based on this, I tried a different USB cable. I was able to run the job on “air” without the spindle running just to see if it would follow the toolpaths. However, when I try to actually carve the carve window crashes as soon as I turn on the spindle. Now the status is Alarm. Here is the top lines from the console:

  • ok
  • $132=100.000
  • $131=750.000
  • $130=750.000
  • $122=50.000
  • $121=500.000
  • $120=500.000
  • $112=2000.000
  • $111=8000.000
  • $110=8000.000
  • $102=49.909
  • $101=26.660
  • $100=26.660

Check you router brushes.

closing this one out as I got it resolved. Here’s all the things we tried along the way:

  • swapped router brushes
  • plugged router into a different outlet on a separate circuit
  • pulled router power cable out of the cable guard
  • used a USB with external power source
  • used a shielded USB cable
  • used a shielded USB cable (USB A to mini-USB B), bypassing the bulkhead and plugging directly into the controller board
  • replaced the controller board and the ribbon cables that connect the boards
  • and FINALLY… replaced the router

I’m pretty sure the router replacement alone would have fixed it, but maybe it was a combination of the things we tried. Either way, glad to be back up and working.