Inventables Community Forum

Carvey, F360, facing operation, Smart Clamp Z override?

I’m working w/ wood of slightly-varying heights.

The first F360 operation is a facing cut to get it down to the model size.

Because Carvey pings off the smart clamp it “knows” the height of the wood–I want it to not do that. To put it another way:

  • My model height is 0.5"
  • Stock height in F360 is 0.75"
  • I want Carvey to pretend it’s 0.75" even know it knows the height
  • I want this to happen w/o having to use any jigs/fixtures/shims
  • I’d prefer to not have to manually edit the GCode, but can script this if it’s the only way

At the beginning of the operation it would be machining air, i.e., the stock height from F360 is greater than the actual stock height.

When I load the GCode it says it uses the material height from the GCode, but it’s removing 0.25" material from the top of the actual material, which indicates it’s still using the Smart Clamp Z offset.

I’ve also tried setting the origin in F360 to the bottom of the stock (instead of the top) but then Easel appears to use the Z probe height as the stock top, so it’s ~ stock height above the surface of the material.

I tried exporting the GCode but I don’t see a homing sequence I can remove.

Any ideas?

Can you share your Fusion file?
Are you committed to Easel?

It’s any file; I can share my test part, but it doesn’t really matter—issue would be the same regardless.

I don’t care if I end up using Easel or not. What I’d prefer is to be able to use the probe to offset the entire process but I don’t think I can use the F360 WCS probing for that. I haven’t tried connecting to the Carvey with anything else, but certainly can (computers are my super-power).

Saves me from making an example (I can get to that after I get the kids to bed).

Here are a couple ways to do this:
Set your origin at a point .25" below the surface of the stock.
Set you top height .25" above the stock surface.

The homing/probing will occur if you use Easel. No hand or script editing would change that.

I guess mine is getting my machines to do what I want. :wink:

1 Like