Inventables Community Forum

Carvey Homing to wrong Z direction

Hello guys,

I got a trouble after several times emergency shutdown…
My CARVEY going down directly after I press HOME, what can I do?

new update 01:
I have two CARVEY, I just took another one’s motherboard and install it into this machine, and it works well. So the issue could be on the motherboard, right?

Need your help, please!
Jay Chen

The home direction is controlled via $23 of your grbl settings. You need to read the current value and then use the chart found here (scroll up to $2 for the chart to refereence) to adjust the setting for $23

1 Like

Hi Jay,
I assume you didn’t change any settings?
If you unlock the machine ($X) can you jog the Z up and down? Does it only move down?

Hey Neil, thanks for your quick reply.
I unlock the machine ($X) but don’t know how to jog Z up and down on my Carvey.
Is it allowed to jog Carvey?


update 02:
I tried to debug the hardware part, so far I found this set from new machine makes the Homing fail.
Both motherboards on the other backboard set are working fine, and both motherboards homing failed on this one.

any hints?

the working well motherboard = MB_original
the issue motherboard = MB_broken

update 03:
Well, now the motherboard issue is back.
No matter I connect which backboard set, when I use the MB_broken, the spindle goes down directly after I click HOME from Machine.
So it’s not just wiring issue. Or it should not be the wiring issue on backboard set.

This CARVEY had its own issue from day one, unboxing.
It’s PWR connection had issue with bad 5016H soldering on cable side.
The Inventables support team told me, this could happen because the power issue.

the items which I replaced already are:
(1) PSU adapter
(2) 2P 5016H Male Receptacle
(3) POWER wire from backboard PWR switch to 5016H
Here is the item I would like to replace as well later.
(1) 2P 5016H Female on board

Need your help please.

G91
G0Z1
G90

Will jog up one millimeter.

G91
G0Z-1
G90

Will jog down one millimeter.

1 Like

There are two case so far I have with this motherboard.

Home Failed case_01 : move down directly
Home Failed case_02 : can’t finish homing

Have you tried jogging up and down?
Erratic motion could be a wiring issue.

Can you check the Z limit status? It could be an issue with the switch. If it is shown as pressed, you’ll get homing issues. My guess is an issue with the switch.

Erratic motion only happens when I install this motherboard on this CARVEY.
Replace the motherboard from another CARVEY, then everything works well on this machine.

Yes, both Jogging Z+ and Z- are with tiny current noise but no moving.
Even with bigger value.

Z limit status works, most sensors on the screen I can test are working well.
(can’t upload my screenshots for some reason on this forum?)

The videos above are with the good controller?

The motion seems smooth…not typical of a bad motor driver.

If the Z switch is working correctly and there are no issues with the wiring/connectors, you might have a bad motor driver which means you’d need to replace the whole board. I would triple check everything else before you do that though.

It’s possible you see Z issues if the lead screw nut is loose, or of a pulley is slipping, but I don’t think you’d see motion in the opposite direction.

The videos above are with the good controller?
yes

There are 3 chipsets for 3 axes, I have no idea which one is for Z axis.

Guess those are X / Y / Z controllers in this image.

How can I check if it’s the Z motor driver issue?
I will run some G-code, to jog all X / Y and Z axis and check now.

After a bit test, I don’t know if it is a normal way to call CARVEY…
I have use these commands…

$X
G91
G0X10 --work!
G0X-10 --work!
G0Y10 --work!
G0Y-10 --work!
G0Z1 --work!
G0Z-1 --work!
G90

Everything seems work fine, so I click HOME, but Homing failed again.
Then I did another test run G-code immediately.

$X
G91
G0X10 --work!
G0X-10 --work!
G0Y10 --work!
G0Y-10 --work!
G0Z1 --failed!
G0Z-1 --failed!
G90

I have an idea, but not sure if it’s too risky.
Can I switch the motor cables, use either X or Y motor driver, to connect to Z motor?
Then I use G91 to test a bit?
What do you think, @NeilFerreri1 ?

How did the homing fail? Motion or no motion?

Z axis = no motion. Just tiny current noise.

If you have it jog a longer distance (Z10 or Z-10) what happens?

You should be able to switch the axes cables, X for Z, and see what happens. It won’t move the correct distance though

I did check G0Z10 after that test run, no motion.

I will switch X and Z axes cables, and run Z10 and X10.
After that, will have a close look of Z motor driver later.

wow, I find something weird…

Your hint just saved my CARVEY!
It’s homing now!
Almost place an order of that motor driver TMC261-PA chipset.
You are my lifesaver, Neil!
It’s so kind of you to help me out today.
I can’t thank you enough.

Jay Chen

1 Like