Changing bits moving axis

In the past i would do a multiple step cut with different bits in order to speed my project times up. In the past couple months i have been unsuccessful in switching out the bits without jerking the machine which in turn would throw off my zero. And a lot of times because of this my project would be ruined because i couldn’t get it back to the exact same zero. I tightened the belts thinking maybe they weren’t tight enough to hold everything in place while i loosened the bit but that only worked for about 2 times. I also have tried not tightening my bits in the machine as tight and as the machine runs it still is kind of hard to get that initial tightness to break loose on the collet.

Is it possible that my x and y motors are getting worn and not strong enough to resist me loosening the bit? That’s the only other thing i can think of.

Has anyone else had this problem?

I move the carriage every time I try to change bits. Supposedly you can turn off the 4th dip switch for each axis on the x controller to keep the motors in place. There is also a $ setting that needs to change if you don’t have it already. I haven’t done the dip switch change, I just make home x0y0 and everytime I change bits, I rehome the machine.

1 Like

Make sure $1=255 (GRBL parameter) and that switch #4 on all axes are set = OFF

Do you have homing switches installed?

1 Like

Just don’t go full Chuck Norris when you change your bits. :wink:

Have you ever seen one of these? With it your zeroing problems are over. Yes even if you change a bit and loose your zero for all three axis you can get it back to where it was in the beginning of your carve… yes, all three axis.

www.triquetra-cnc.com.

1 Like

And I figured out how to use it for automagic 3-axis zeroing in Easel!

I do have homing switches. But where do I go to turn switch #4 on all axis off?

1 - Great, that means you have the ability to consistently syncronize machine space with work space. Your work zero is stored as an offset from machine zero.
After powering up your CNC, home the machine, then find your work zero and carve.
Should you for any reason want to restart the carve, simply rehome your CNC and choose “Use previous home position”. I would jog the machine above and over the intended work zero position prior to choosing “Use previous home”

2 - Open up the cover of your Xcontroller, you´ll find switch #4 on the red switch boxes inside.

This the post I’ve been looking for! :grinning:

Disclaimer: I’m new to X-Carve. Just finished building my Nov 2021 version machine over the Thanksgiving day weekend.

I’m trying my best to not go “Chuck Norris” but it seems I can’t avoid moving the work zero when change bits. Consistently killing my results (thankfully I’m running a lot of tests). Can someone kindly explain what I need to do to fix this other than not tightening my collet (I really try not to over tighten it, honestly)?

I have three homing switches.

Thank you!

Did you implement this change?

1 Like

No but I will, thank you!