Chilipeppr FYI Always output gcode in MM

Anyone else have this issue? Seems the GRBL port of chilipeppr isn’t a fan of imperial units. I noticed that I will run my gcode and the first thing that happens is it parks for tool change. At this point, the gcode has already put the board into inches mode, however, the display in chili doesn’t update. So hit 10 and jog. You will jog 10 inches instead of 10mm. This wasn’t so bad until I started using the touchplate widget. This widget will not work if the document has put the board into inches. You can only enter values into the touchplate widget using metric units and no matter how many times I zero the bit it never comes out right. I have resorted to setting my gcode in Fusion360 to output in “Metric” instead of “Document Units”. Now everything is always metric no matter what and I don’t have to remember where I am and what unit I am in.

PS - Try manually sending the board the MM command so that you can jog with the correct units during a tool change. Now forget to set it back to inches before unpausing. Watch your xcarve cut a very tiny version of your part haha.



Allways use Metric is my conclusion :smile:

Haha I always switching back and forth. It normally just depends on what I am modeling. If I am working off of something that is in metric then its easier to base my design in metric (cases and the like).

Just thought the behavior was strange. Now if only I could find a way to force fusion360 to just always select metric in the post processor instead of defaulting to document units.

1 Like