Circle is not a circle

My kid asked me to make a fidget spinner, and the hole/circle for the ball bearing wasn’t a perfect circle. The top right had too much carved away. On the drawing below it should have been the blue line, but on the top right it followed the red line. Not as bad as the drawing in real life, but enough to make it visible without measuring. Maybe it is related to firmware 1.1f?

Scaling to a bigger circle doesn’t make it worse. It’s the same amount of gab/space, going from 12 to 3 a clock. Lets say it about 0.3mm on a circle that is 10mm in diameter. Making a circle that is 70mm i diameter, the gab is still 0.3mm.

Making a circle in Easel and importing G-Code from Fusion 360 gives the same result.

I tried searching the forum for answer, but couldn’t find one. I have tried the following:

  • Different bits.
  • Different feedrates.
  • Checked belts.
  • Checked everything for missing/loose bolts.
  • Made sure everything had loctite (e.g. pulleys)
  • Checked V-Wheels.
  • Calibrated X and Y again.
  • Removed Y1 power and checked that Y2 worked and vice versa.
  • Did the machine setup again.
  • Check GBRL settings.

I am using the X-Controller.

I hope there is some simple answer to my problem. I think is started after firmware 1.1f, but I’m not sure. I don’t think I every need at perfect circle/hole before :slight_smile:

Sounds like Z axis flex or X axis slack in the belt.

I found that accuracy improves a lot when you lift the cutting area by putting some MDF on top of your wasteboard. When the lower Z wheels align with the lower X gantry wheels I get the best results.

Have you checked the power consumption of your stepper motors? Uneven load on the Y motors can make them turn in the right direction but movement may be uneven.

If you doubt 1.1f you can go back to 1.0C to see if that supports your conlusion.

Had the same problem adjusted belt tension in the process figured out my x and y got bumped out of square. I setup some stops to make sure it’s square before I turn on the controller and it locks the nemas problem fixed. I’m guessing if you measure from the x end plate to the y end plate on both sides the one on the right side will be father away then the one on the left .

It is mechanical. You have different rigidity/level of “give” between the X & Y axis and it manifest itself when transitioning from one axis to the other. You would also see a similar defect on the lower 3rd quadrant.
My bet is that your Y, or rigidity on Z, need a little attention :slight_smile:

1 Like

Your are right. It’s smaller in the 3rd quadrant, so I didn’t notice it at first. I’m not sure what to do about it :frowning: Maybe the V-wheels is to tight. The Z axis with the X axis upgrade is as good as it gets (I think). I’ll run everything over one more time.

But that shouldn’t make any difference in a circle? Unless X/Y isn’t calibrated correctly. Carving a square works as it should (or the error is too small to see).

Thx everyone for your help. I have solved my problem, but I’m not sure how. I changed all the eccentric nut to eccentric spacers. Readjusted all V-Wheels (those without eccentric spacers). Took of the X Stepper and checked the pulley and put everything back together. Somewhere along the way, I solved the problem @HaldorLonningdal talked about.

:joy: :joy: :joy: :joy:


Circles not circles is usually:

  1. v-wheels
  2. belt tension
  3. Pot voltage

Any or all.