CNC 3018 PRO step motors do not move

Hi to all,

I am new to this forum and many thanks to everyone. I am also new to the fantastic world of carving. Actually, I am experiencing problems with the step motors of my CNC 3018 PRO. The fact is that when I connect the machine (that now I use as laser engraver) using Lasergrbl and I try to move the X- or Y- or Z-axis, just to check if there are issues, the motors seem not to move. I just hear a noise like something is moving, but nothing happen. What I observed is:

  • MACHINE TURNED OFF: I am able to rotate the motors and all the axes can move;
  • MACHINE TURNED ON: I am not able to rotate the axis;
  • When I adjust the feed rate, the problem still persists
  • the driver is installed because COM3 is the port which the machine can connect to the computer;
  • the same problem is shown when I use Candle
  • When I reset the motherboard, by pushing the button RESET, the problem still persists
  • When I re-install the driver, the problem still persists

Any comments, tips, advices are very much appreciated

Many thanks

Welcome to the forum :wave:

What is the feed rate set to?

What state is showing in candle? (Idle standby or alarm)

Also what are the grbl settings?
(These can be found by sending the command $$ in the console at the bottom right in candle)

Hi and thanks

I am using Lasergrbl, because I want to use the machine as Laser engraver. I attach an image to answer your questions

Grbl settings

$0=5 (Step pulse time)
$1=5 (Step idle delay)
$2=2 (Step pulse invert)
$3=5 (Step direction invert)
$4=1 (Invert step enable pin)
$5=0 (Invert limit pins)
$6=0 (Invert probe pin)
$10=1 (Status report options)
$11=0.010 (Junction deviation)
$12=0.002 (Arc tolerance)
$13=0 (Report in inches)
$20=0 (Soft limits enable)
$21=0 (Hard limits enable)
$22=0 (Homing cycle enable)
$23=0 (Homing direction invert)
$24=25.000 (Homing locate feed rate)
$25=500.000 (Homing search seek rate)
$26=250 (Homing switch debounce delay)
$27=1.000 (Homing switch pull-off distance)
$30=1000 (Maximum spindle speed)
$31=0 (Minimum spindle speed)
$32=1 (Laser-mode enable)
$100=1600.000 (X-axis travel resolution)
$101=1600.000 (Y-axis travel resolution)
$102=1600.000 (Z-axis travel resolution)
$110=1000.000 (X-axis maximum rate)
$111=1000.000 (Y-axis maximum rate)
$112=800.000 (Z-axis maximum rate)
$120=30.000 (X-axis acceleration)
$121=30.000 (Y-axis acceleration)
$122=30.000 (Z-axis acceleration)
$130=200.000 (X-axis maximum travel)
$131=200.000 (Y-axis maximum travel)
$132=200.000 (Z-axis maximum travel)

Ok, all those look good, I was afraid that the settings were set so slow it was moving but at the speed of molasses…

One thing that could be the issue is the com port assignment number… sometimes windows doesn’t like 1-3 and reserves them for keyboard, mouse, and printer… so you can try a different usb port and that will change the number assignment, or you can go into device manager, the ports section, go into properties>advanced and then manually change the number to 4 or higher…

I’ve also found that restarting windows with the usb plugged in will cause windows to automatically locate the latest version of the driver and install automatically during the boot up… so you could try that at well :thinking:

many thanks for the advices. The COM3 worked before this issue. I will try a different COM port

1 Like

… also, it is not the COM port because the problem still persists when the COM port is set to COM4. I think that the motherboard needs to be changed

1 Like