CNC 3018 problems with Z-axis

just downloaded Easel and although i have got all the axis operating , i seem to have problem with home regarding the Z-axis. it just sends it to the upper limits of the thread causing unhealthy noise. also when trying to carve a project the z-axis never seems to be at the correct height to actually cut anything

If homing fails then its most likely missing, not triggering or the homing switch is incorrectly wired. You can test and verify by opening Easel’s Machine Inspector pane (Shortcut, CTRL+SHIFT+D)

In that pane the MI visualize three “LEDS” one for each axis. Trigger each switch by hand and the LED should display green. If not there is a wiring issue.

Homing follow the following sequence:

  • Z first, hit twice
  • If Z is detected XandY will follow in unison.
  • If Z is NOT detected, it will time out and prompt an alarm.

Z axis issues…I’ve seen somewhere? It might be a Windows 10…issue. I’ve tried everything. Worked fine till Easel put out the new driver. God damn Virus I say!

When the new driver was installed into the PC Easel should have then prompted the user to redo the Machine Setup within Easel and IF the incorrect model cnc was selected and an X-Carve option was selected, than Easel WILL change the calibration setting of the X,Y and Z axises.
This can cause the issue described above, so make sure your axises are moving the correct commanded amounts, this can be achieved by performing the manual calibration shown here: