Connecting to the X-controller


So along with a large list of other upgrades i ordered an X-controller to replace the old Ardiuno and G-sheild set up. I’ve built the controller and got the machine back together. Now the issues start.

To start with i couldnt get my windows 10 laptop to even seen the controller. I ended up formating the laptop and starting again. After installing the Arduino drivers and then installing the easel drivers, Easel will now see the controller and let me move the machine around for about 1-2mins before it disconnects and can’t see it again. If i unplug the USB and power down and then reconnect and power back up, roughly 1 in 5 attemps work again for only a few moments until it disconnects again.

Any ideas? Feeling i have a duff controller right now.

There have been some issues discussed around here about bad crimps on the E-Stop. I would start with that first. Sounds like a faulty connection.

Arduino drivers aren’t needed for Xcontroller.

Install the FTDI drivers from here

And check your Estop crimps as was mentioned by Curtis.

Are the issues with the router on? Have you tried shielded cables and/or a powered usb hub?

Thanks, i’ll check the E stop tonight. The E stop switch itself seems rather rubbish, it feels like a cheap part. We have a few machine tools at my day job and all of the e-stops feel a lot better and spring back when you release them. The X-controller on i need to pull out, so far it feels very expensive for a not brillaint bit of kit.

havn’t got as far as switching the router on yet. I’ve tried a powered usb hub but seems to make no difference.

checked the e stop wiring. Looks fine, checked it all with a meter and its working.

I keep getting an error saying on the com port

i’ve installed the FTDI drivers but nothing.

Getting really fed up with this thing. I might return it and go back to the old set up.

leave it a little bit of time, turn the controller off and on again and the com port is now fine but easel still doesn’t see it.

plugged in my old controller and it first right up. Laptop see its no problem and easel will see it too.

Well it looks like it terminal. Inventables are sending me out a replacement controller.