Inventables Community Forum

Connection question

So Inventables has been very good in helping me resolve my issues.
Yesterday I received a new controller board from them
I installed the board, turned everything on, and this is what I get…

I am by no means a computer wiz, so this morning I started doing some research in the smartest place on earth (Google)
So now I know how to check my com port setting and this is what I find.


So now the question becomes, Is that bits per second supposed to be set at 115200?
Could this have been my problem all along?

try maxing out the bits per second setting on the com properties

Yup, tried changing the settings but got the same message.

The Windows com settings most likely don’t matter. Picsender will set the com port settings to what it’s configured to do. Make sure Picsender knows that you should be using COM3 or else you could get that error.

Your device manager also shows 2 USB COM ports…make sure you know which is the Xcontroller. I like to unplug and replug the device while in device manager to see which one goes away and comes back.

Thanks for the responses.
Yes, Picsender is set for 115200.
But when I checked my com port settings it was at 9600.
So I thought that , that may be the problem.
But it didn’t make any difference.
I still got he same message.
I wait to see what Inventables comes up with for a solution.

I need help! I have tried everything and I cant get easel to light up the CARVE button. even changed the usb cable. running in new computer with windows 10.

this has happened many times since my x carve 1000 was new but was able to fix by turning on and off and in an out with the usb cable. Have not been able to get to the carve green light for 3 days. sure hope I can get this fixed.

Jan, when PicSender starts it polls all the com ports to see what com ports are in use. Clicking on the com port selection will show these to you. Your controller’s com port, if connected to one of your USB ports, will be in the list. Select one at a time until you can connect. Thereafter, PicSender will remember your chosen setting when you shut PicSender down using the Exit button.

Did you already try this?

EDIT: This is covered on page 4 of the Tutorial in PicSender.

1 Like

Thank you for the responses.
Robert,
the full screen is of the picsender.
it shows Com 3 and 115200 rate

John,
I did not do that because I don’t believe that I have an issue with Picsender. (I thought that you and I have already determined that)
I really don’t know anything about com ports and I didn’t even know how to find them until yesterday morning when I Goggled it.
Picsender shows Com 3.
so when I finally found my com ports, I clicked on com 3 and found it was set at 9600.
I did change the setting to 115200 but still got the same message when I tried to start the machine.

Jan, changing the com port in anything other than the sender you are using, will not work. For PicSender, you must set it correctly as I described, and for the other senders that I have examined, too.

It is likely that the new board you received from Inventables uses a different com port assignment than your old board. PicSender may show the wrong com port because that was for your old board (?) and it remembers it.

2 Likes

WOW John,.,
I will get to the shop this afternoon and try it again.
Thank you.

Jan,
This is what my development computer shows at the moment. I have 5 different versions of grbl connected for testing purposes. Com1 is reserved by Windows (Win 7 in my case).

I just point and click on the one I want to test and click Open to near instantly switch grbl versions.

1 Like

Well if I’m understanding it correctly, (by the screen shot above) I only have 2 com ports?
So if com 3 doesn’t work, then it must be com 4? correct?

But I have 4 USB ports on my laptop.
I’m truly missing something here.

If you had a hundred USB ports on your computer, it would not matter. It is only the com port number assigned to your board that matters. The same board plugged into any one of your imagined 100 USB ports would show the same assigned com port number.

EDIT: In my above screen shot, I do not have 34 USB ports on my computer, but I do have Unos with Com28 and Com34 connected.

“then it must be com 4? correct?”
No, it may not be com 4. Could be com (any number).

1 Like

John,
So I’m reading your tutorial.
if I click on the com button, will picsender detect the correct com port?
And then I only have to click on it?

Oh,
I think you answered that question above.

Yeah, I saw your post from earlier too.
I will get to the shop this afternoon and try again.
If I had been paying closer to the posts from yesterday, I may very well have my problem resolved by now.
But when stuff like this happens (which I don’t understand) I get very frustrated just leave the shop and have a beer.
Thanks for your input.

2 Likes

So I just got home and fired up the Xcarve.
Sure enough, I needed to connect to Com 4.
But now nothing moves in a predictable manner.
Is there something else that I need to do?

every thing is running backwards.

I am going through the tutorial and don’t have a clue as to how to doe that.
I thought that I loaded Larry’s file but for sure, I’m doing something wrong.

if I do, I don’t know it and I’m at a complete F loss right now.

it wont clear the alarm limit switch