Cut Drifting

I just finished building my CNC last weekend, I was lucky enough to stumble upon Easel. I’m liking the ease of use of the program but I’m having an issue. When the machine makes multiple passes, the bit drifts to one side.

Both of these cutouts were made from the same file, I just rotated it 90deg and redid the cut. nothing else was changed. I’m not thinking its an issue with my machine since the cut goes towards the same side of the image no matter how it’s rotated. Has anyone else had this issue? Any ideas on fixing it?

Can you see the tool paths offsetting in the 3d preview?

No, they look straight when I do the preview.

Is that a shape that you drew in Easel or imported .svg? If imported, try drawing a shape directly in Easel an run it on a scrap of material.

Phil, notice the 90 degree rotation and the drift orientation. What do you make of that? Kind of looks like a bad tool path.

1 Like

It’s on a home built machine. Controlled with an Arduino uno/GRBL, tb6560 drivers, Nema 17 steppers and a 12v 30a power supply. It’s cutting with a dremel and 1/8" straight cut router bit. It has the drift whether I’m cutting that pink insulation foam or wood (pine, balsa, and a piece of mahogany).
I thought it was an issue with my machine so I swapped the steppers around, changed out the power supply and cutting bit, tried cutting different materials… once I realized that it was drifting the same direction on the image no matter how it was rotated, now I’m stumped. I’ll have to try and cut something out that I make entirely in Easel and see if it makes a difference.

1 Like

Have you calibrated the current limit on your stepper drivers?
Having this set too low will make you loose steps.

But atleast make sure your spindle / cutter bit is perpendicular to the wasteboard both in X & Y direction.

slipping pulley maybe?

I believe it’s running GRBL 1.1? Whatever the most current version is, I downloaded it last week. I’ve tried changing every setting on the stepper drivers that I could, changed out the bit in my dremel (zip bit to a router bit), changed feed and depth settings (faster\slower) and I was convinced it had something to do with my machine build until I rotated the image 90deg and got that cut shown in the image above.

I haven’t done a compicated cut using only an Easel image yet. I cut out some lettering in that pink foam but it was only a single pass cut, so that doesn’t help me right now, lol. When I get home tonight I’ll try a different cut and see where that gets me.

Photo of my build, not 100% completed yet, at least until I get this issue figured out.

He has stepping in both X and Y, or am I seeing something not there?

Might be sloppy spindle bearing???

If it’s Easel, can you export the Gcode and post it?

This is a link to the project. I made the image in photoshop and used the image trace function to import into Easel.

this was the image I used, except it was the original not a printed out version. I imported with image trace, selected trace outside then imported. it gave me 5 separate images, I deleted all but the middle one then chose to cut outside the path giving me the outline of the dog. I can upload the original image when I get home later.

Im confused, did I set something wrong?

I opened easel, imported a jpeg file of that image and made my cut.

This 100% made the difference. I can’t thank you enough.

1 Like

I loaded the GRBL 1.0c hex you linked me to a couple posts up. I cut this out as well.


The one I posted that worked correctly was the same project file I posted before. I’m using the full version of it to do this right now.

I appreciate all the help and suggestions from everyone, btw. It would have taken me way longer to figure this out if you all hadn’t helped out.

Thank you.