Cut randomly stopping during job

I’m at my wits’ end, I have tried reading all the forum posts I can about this issue and still not getting a resolution so I’m hoping if I post my issue someone can help nail it down.

Problem: Every time I run a cut my X-Carve stops mid cut and won’t do anything so I have to home and start over.

My setup: I have a 2015 1000 mm X-Carve with Arduino/Gshield with limit switches, ACME rod, and Nema 23 steppers. It has a Makita RT0701C for a spindle. I haven’t used it in years until this last week when I took on a task for my work and now am having problems so cannot deliver.

My attempted solutions (I started running a longer file that was about 30 minutes to give it time to fail and each time got a random stop so tried again after making another change and still it stops every single time, sometimes 5 minutes in, sometimes 15):

  1. I made sure my computer wasn’t going to sleep. Even tried actively using the computer the whole time to make sure.
  2. I have tried getting a “better” surge protector, spent $55 on an APC SurgeArrest (model P11U2).
  3. I got an externally powered USB hub for my laptop to make sure it wasn’t losing USB power.
  4. Adjusted my pots (based off a few different posts, I think I did it correctly but who knows at this point. Though I’m not certain the pots would cause this specific issue since it seems to be tied to the limit switches)
  5. I switched from Easel to UGS. I was having all kinds of issues just jogging in Easel plus a weird .dxf import problem so switched to using my original Fusion360 file to generate the gcode instead of exporting a .dxf, importing to Easel, and using Easel to generate the gcode. Then I ran the Fusion360 gcode in UGS. Once I switched to UGS, that’s how I am getting an alarm code: “[Error] An error was detected while sending ‘X362.767Y71.368’: (ALARM:1) Hard limit has been triggered. Machine position is likely lost due to sudden halt. Re-homing is highly recommended. Streaming has been paused.” I have to do a Soft Reset and Home after this happens to get it to start working again. I tested and get the same code when I manually press a limit switch during a cut. This code lead me to believe (based on forum research) that it was a limit switch alarm which I found was possibly due to EMI triggering them so next I…
  6. …Stopped using my shopvac dust collector temporarily due to possible static discharge and …
  7. … Ran a ground wire from my router body to the outlet (and checked continuity to make sure it was connected). Then I realized this shouldn’t even matter because I am not even turning the router on, I am doing “air” cutting with the router off. I was also trying to use the IoT relay to auto-start/stop the router and thought that was the culprit but since it’s doing it even with the router off I think it’s something else.
  8. I found some old ferite clips I had in a box of cords and put one around the three sets of limit switch wires where they exit the drag chain because one forum post mentioned them.
  9. I saw something about disabling limit switches in UGS so I tried that in the setup wizard but then it disables homing and soft limits and I don’t quite understand how to reference home, work zero or safely move without a home set by limit switches (may be because I am pretty amateur at this since I haven’t used it in years and even then only did basic cuts in Easel, never messed with anything else). I then only changed $21 to 0 in the firmware settings but that did give me an error (I assume because I only changed $21 and not the other options that it wanted me to change regarding homing with no hard limits). When I tried this method it did finish for once but I’m afraid of what it may do (i.e., crashes or changing positions) without them on, after all they are there for a reason, right?
  10. I even disabled my bluetooth speaker and moved my phone to another room because I’m desperately trying everything.

Please help, I am so lost!

1 Like

Hard limits and homing are independent of each other. $21=0 to disable hard limits. $22=1 should enable homing

How old are your brushes in your router, when mine are towards the end of their life they do this to me. I also blow out my router after every couple of projects.

Had the same problem. My apparent solution, an “APC UPS Battery Backup & Surge Protector, BE600M1.” (Amazon)

“UPS” stands for “Uninterruptible Power Supply.” My unit has 5 “surge only” plugs, 2 “battery backup” plugs and a “USB” charging port.

My X-Carve Controller and Laptop are plugged into the battery backup plugs and all my peripherals into the surge plugs. Roughing carves are 2-3 hours, finishing 7-8 hours… no interruptions… zero.

Note: Just added a “Ring” Video Door Bell next to my 1000mm to monitor the long carves remotely. Also, the UPS is plugged into an an Amazon Alexa Smart Plug, while the overhead shop lights are plugged into a separate Alexa Plug. So, when I, remotely, see the spindle has finished a carve, I can shut the whole shop down, X-Carve, lights, etc.