Cutting thick material with Carvey - Smart Clamp Bolt too short


I am trying to experiment cutting a 1.5" inch thick piece of pine wood.
The Smart Clamp bolt goes to 1" only.

Do I just go to hardware store and try to get longer bolt so I can set the Smart Clamp on the thick material ?

Is the bolt M3 in size ?

Is there anything to watch out ?


Sze C

Okay. I find out another discussion the bolt is M5.

Try using double sided carpet tape, or use screws to hold down your piece outside your cutting boundary. You might also try using a set of stops like these:

Thanks. Going to get some M5s.

what’s the longest size screw that will work? or will anything longer than stock bottom out with thinner material. in which case, which length screw for the max thickness for the carvey?

would you recommend a m5x70mm or m5x80mm?

Hello I am getting some M5s and waiting for them now. Will post once I got some and have something thick secure on the waste board on Carvey. Stay tune.

you need to make sure your smart clamp is clamping to top face of material - otherwise you run the risk of Carvey retracting and moving at rapid into the job = ouch

Ok. I got the M5. 6cm. They are all stainless steel. Nice.
Clamp the wood down and get Easel going. Whoops Easel Crash ! ( That is another story).
Finally I think I got the Windows 7 -> Chrome -> Easel - Carvey sorted.

In the end it worked. Carvey finally mill out the job. I hope this help.

How long did that take to carve?

Where did you find the M5 screws? I tried searching McMasterCarr but couldn’t find the exact type I’m looking for.

Sorry, I do not have an accurate time for the cutting process.
This milling job is a test of my computers hardware talking to Easel then to Carvey.

Here is a long winded version.
I did ran the first standard test job from Carvey and it was fine. However I want to run a much longer job to see if there is any problem with my computers. Initially, I was using an old Mac Book pro( old - pre thunderbolt, usb 2 only ). Ran the job test job and it works. Time to step it up. So I ran this job (Fatbars). Problem starts.

The Macbook Pro will start the milling job until it reaches 25% to 40% the old Mac Book will hang. I have to shut down Carvey and reboot the old MacBook pro. I checked the version of Chrome I am running and it s the latest.

This time I start sectioning the milling job. I have multiple version of Easel file for different part of the job. Right now Easel do not have a Jog or Fast Forward function where you can tell Carvey to jump to certain part of cutting position (like telling Carvey to move to certain part of the G-Code file and start there instead). Well, the Macbook Crash again. Not cool. Time to switch to my old Win 7 PC.

Window 7 PC took me a bit to get the proper device driver to talk to Carvey. This is also an old Core 2 Dual PC.
Got it it going and started milling. This seems to be better then my old Macbook Pro. Finally, Carvey finish cutting the job. Yeah.

What I learn so far.
My old machines are old. The Macbook Pro only have USB 2. The Macbook pro lost communication between itself and Carvey. The Core 2 Dual PC is old. However, I have USB 3 on pc. I talked to support and asked them if getting Windows 10 will help my set up and they said yes. I am looking into that now. Also, I suspect the USB cable that I am using is not good. I will also change the USB cable.

That’s it. Got to mill some more and test some more.

1 Like

Hello, McMasterCarr, that is like Aladdin’s cave for hardware. I do not live in USA.
I got my mine at a local hardware store that specialised in stainless steel hardware.

I wish I can catalogue shopping like McMasterCarr where I live.

I just took a look at McMaster-Carr. Here is the page I think. Good luck.

1 Like

amazon has a good deal on it

but i don’t need 100. anyone interested in splitting?